1997 STX1100 Running or Carb Issue
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 5 of 5
  1. #1
    PWCToday Newbie
    Join Date
    Jun 2022
    Location
    Ohio
    Posts
    3

    1997 STX1100 Running or Carb Issue

    Picked up this ski and the PO said it would not run well. I pulled the carbs and rebuilt them. Pulled the reeds and cleaned debris from the rubber carb stack tubes. I tried to get it to run and had no luck with what appeared to be no fuel flowing to from the carbs through the venturi. I bought a second set of carbs used and tried them, same issue. I tried a bunch of things to get the carbs working. I pulled the return fuel line and ran it to a gas can. I put a new return line back to the fuel tank and pressurized it with a compressor. I also ran a new fuel line without the primer bulb in the system. (There was a primer bulb and primer jets installed in the unit). I got it to fire with almost completely closed choke and throttle wide open. But it would not run when the choked was opened regardless of how warm the engine got or if I tried to let off the gas to idle. Also I could see fuel flowing on the forward two carbs, but not the rear carb. I poured gas directly in the rear carb and it appeared to run a little better, but still not without being mostly choked. But no matter what I could not get it to run without playing with the choke and throttle, at some point it would always die. It would occasionally backfire to the point the exhaust got really hot. Also I never got any fuel in the gas tank I had the return line going to.

    Any suggestions or ideas?

  2. #2
    PWCToday Newbie
    Join Date
    Jun 2022
    Location
    Ohio
    Posts
    3

    Re: 1997 STX1100 Running or Carb Issue

    It will not flow gas through all the carbs and run, but only when I pressurize the gas tank. Also getting backfire flames out the carb now.

    Still looking for ideas.

  3. #3
    PWCToday.com Is My Home Away From Home Ragged Edge Racing's Avatar
    Join Date
    Dec 2004
    Location
    SoCal
    Age
    58
    Posts
    5,114

    Re: 1997 STX1100 Running or Carb Issue

    The pickups in the gas tank could be clogged as each has a filter. Pull it to see and then work your way back. If by chance you have an electric fuel pump(12v), hook it to one of the lines(perhaps at the filter before the carbs) and see if it will draw fuel. If it can, more than likely the fuel line is OK. Could be the fuel selector too.

  4. #4
    PWCToday.com Is My Home Away From Home wmazz's Avatar
    Join Date
    Jul 2013
    Location
    Riverside, CA
    Age
    62
    Posts
    3,219
    Blog Entries
    6

    Re: 1997 STX1100 Running or Carb Issue

    Quote Originally Posted by BCRski View Post
    It will not flow gas through all the carbs and run, but only when I pressurize the gas tank.
    Sounds like the needle and seat on one or more carbs doesn't
    like to open or reopen.

    Often this is misdiagnosed as a fuel pump problem.

    When you took apart the carbs, did you find any problems?
    Were the float diaphragms stiff? Did you replace the float
    diaphragms? Spring? and what is the lever height?



    Bill M.
    Attached Images Attached Images
    Last edited by wmazz; 06-23-2022 at 03:39 AM.
    Horsepower == Speed, RPM != Speed



  5. #5
    PWCToday Newbie
    Join Date
    Jun 2022
    Location
    Ohio
    Posts
    3

    Re: 1997 STX1100 Running or Carb Issue

    I rebuilt one of the sets of carbs and bought the other from someone that said it worked. Both sets of carbs had the same issues. But in the one I rebuilt I did not measure any lever hight. I just installed the replacement parts.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0