Rebuilt motor wont start
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 4 of 4
  1. #1
    Frequent Poster daget24's Avatar
    Join Date
    Feb 2013
    Location
    santa barbara
    Age
    31
    Posts
    241

    Rebuilt motor wont start

    As the title would suggest I just rebuilt the engine in my rxt-x 260 2012. I used all OEM parts, installed a new fuel pump (verfied working at fuel rail) and a new supercharger. The damn thing won start and it's driving me nuts. I have verified that I have spark, verified that the fuel injector are spraying in a good pattern, and verified compression. I had the cylinder lightly honed at a shop and replaced the rings on all the pistons. I had 130, 130, 90 psi but, since the rings have not seated yet, and there was no oil in the cylinders I poured a little oil down the cylinders and now I'm getting 160 160 160. Obviously that will drop when the oil settles, but all cyinders are reading the same. I was able to get it to start for half a second by pouring a small amount of gas into each cylinder.

    Im at a Loss, my only guess is that the motor is slightly out of time. and it getting fuel delivered AFTER the spark. what do you guys thing is going on?
    1 2014 seadoo GTR
    1 1996 seadoo gsx

  2. #2
    Resident Guru
    Join Date
    Oct 2013
    Location
    Ohio
    Posts
    887

    Re: Rebuilt motor wont start

    This may be a silly question since I have never worked on an EFI jet ski. It would be difficult on the trucks and cars I have worked on.

    Is it possible to plug the injector wires into into the wrong injectors?
    2, 1998 TS 770 L, restored and running great as of July 2019 (NO THANKS to the person at SBT, who put the WRONG crankshaft bearing into the rebuilt engine I got from them)

  3. #3
    Frequent Poster daget24's Avatar
    Join Date
    Feb 2013
    Location
    santa barbara
    Age
    31
    Posts
    241

    Re: Rebuilt motor wont start

    Quote Originally Posted by hemmjo View Post
    This may be a silly question since I have never worked on an EFI jet ski. It would be difficult on the trucks and cars I have worked on.

    Is it possible to plug the injector wires into into the wrong injectors?

    thatís a thought. But no, itís not possible. The wiring harness simply wonít allow for something like that. I think the motor is 1/2 out of time. I think the spark plug is firing on the exhaust stroke; instead of the compression stroke.
    1 2014 seadoo GTR
    1 1996 seadoo gsx

  4. #4
    Resident Guru RenoJetTech's Avatar
    Join Date
    Apr 2009
    Location
    Reno,Nv.
    Posts
    1,011

    Re: Rebuilt motor wont start

    Oh s#it springtime ! Maybe Rotor/Flywheel installed incorrectly ? Some Ground not making ground ?
    Hopefully not timing assembly related.
    '88 550-ride plate,intake grate,intake manfold,carb
    '96 GTX-1mm overbore,F/a's,intake grate,port timed for mid and top end
    '95 FX 1- usually take this motor to 753cc with exhaust porting and reeds

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0