650sx running poor and lack of power
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 2 of 2
  1. #1
    PWCToday Regular
    Join Date
    Jun 2008
    Location
    highland,ny
    Age
    47
    Posts
    78

    650sx running poor and lack of power

    Okay guys let's see if we can try to figure this one out want my son a 1989 650sx and buying it we knew that there was some tinkering that needed to be done. After rebuilding the carburetor the fuel pump we got it to run but not real good. We're at the point now where we have to use the primer just about every time to start it. Once it fires up it will run okay but not great. He says that on the bottom end he seems like it's okay but when he is full throttle it's not accelerating the way it should. It takes a while to get up on plane and once on plane that's about it. If he goes to make a sharp turn and he loses speed it does not have any power to accelerate out of it. It's like it's kind of flat mid to high range power. He doesn't weigh much more than 125 lb if that so it shouldn't take that much to get it on plane I think if I was able to ride it I don't believe it would get on plane the way it sounds. On the trailer running it same thing need a primer once even after warm it'll fire kind of run rough on idle and sometimes die then when you hit the throttle it seems like it revs up a little bit and acts like it's hitting a rev limiters. Does anybody have any ideas I'd rather not throw needless money into it. I played with the carburetor adjustments and doesn't seem to run much worse or much better any place that I put them either lean or Rich. Currently I'm 1 1/4 out on the lowjet and 5/8 out on the high jet. I'm pretty much at sea level or a hair above and the internal jets are stock. Took the reeds out yesterday they look like they're in pretty good shape. Timing is set on the money. The best I can tell the only upgrade is a Mariners Red high compression head. Which gets me between 170 and 175 PSI on each cylinder. I have noticed that even after running a while it appears the rear cylinder the spark plug is a little wetter than the front cylinder. I'm at a loss and here in New York the season is winding down. I'd like to try and fix it before the water gets cold and untestable so that we have a good year next year with it. Thanks in advance for any ideas as to what I'm dealing with
    Kyle

  2. #2
    PWCToday Regular
    Join Date
    Jun 2008
    Location
    highland,ny
    Age
    47
    Posts
    78

    Re: 650sx running poor and lack of power

    Oh also on the trailer if I hit it full throttle it will kinda sound like it's hitting a rev limiter (lower rpm range) but if I got the throttle like a 1/16th (lightly feather)of a throttle it will rev to the moon
    Kyle

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0