Warms up after a couple minutes, bogs down, and wont stay running. - Page 2
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    PWCToday Newbie
    Join Date
    Aug 2021
    Location
    Iowa
    Age
    45
    Posts
    9

    Re: Warms up after a couple minutes, bogs down, and wont stay running.

    Im going to set up a test "tank" in my garage so I can run it under load without travel back forth to the lake. I thought I a pretty smart guy, but this has me scratching my head bad...

  2. #12
    PWCToday Newbie
    Join Date
    Mar 2020
    Location
    Waverly NE
    Posts
    14

    Re: Warms up after a couple minutes, bogs down, and wont stay running.

    Overtemp sensor?

    Gasket leak or oil port cover leak on the intake side or crank seal? Sounds like how ours acted before it progressively got worse before lean grenading.
    Last edited by HawkZ28; 09-13-2021 at 09:25 PM.

  3. #13
    PWCToday Newbie
    Join Date
    Aug 2021
    Location
    Iowa
    Age
    45
    Posts
    9

    Re: Warms up after a couple minutes, bogs down, and wont stay running.

    I haven't had the overtemp sensor hooked up the last three times I've ran it. I got the high jet backed out almost two turns now and the low jet like little over a half turn. Got it running in the garage water tank really good for at least 30 minutes. Seems like the exhaust doesn't like to be burried in the water so I removed that cup and I'm going to modify so it exhausts right at water level when its weighted down in the water. Got the carburator tuned in, I think in my smoked up testing bay. I think the back pressure from water in exhaust outlet was causing problems. heading to the lake again to hopefully ride. Oh yes and I leak tested the whole engine before I ran these last two times and it held 8 psi for 30 minutes. I'm convinced the water backpressure on the exhaust is the problem.

  4. #14
    PWCToday.com Is My Home Away From Home Myself's Avatar
    Join Date
    Jun 2006
    Location
    Arkansas
    Age
    45
    Posts
    6,792

    Re: Warms up after a couple minutes, bogs down, and wont stay running.

    Have you removed and inspected the exhaust hoses? Sometimes they blister inside and create a 'flapper' blocking exhaust flow.
    http://www.facebook.com/twinlakesjetskirepair

    '89 Kawi 650SX 42.4 GPS
    +3" stock pipe, ported ex. manifold, drilled waterbox, blueprinted pump, Ocean Pro ride plate

    '99 Yama GP1200 65U 61.8 GPS
    ported cylinders, matched cases, milled head, blueprinted pump, long ride plate

    '96 Seadoo HX 717 53.13 GPS
    light porting, massaged cases, lightened flywheel, port matched manifolds, Rossier pipe, stubby pump cone

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0