Polaris SL700 1996 no start, help?
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 7 of 7
  1. #1
    PWCToday Newbie
    Join Date
    Feb 2021
    Location
    Millstadt
    Age
    46
    Posts
    5

    Polaris SL700 1996 no start, help?

    Im posting this in the general help(ish) forum knowing my problem likely is not specific to Polaris, hoping to pull help from more members.

    So i bought an old (clean) Polaris SL700, i get it home& get into it... no start, doesnt even "click"

    I look all around everything looks great,.. cant see any obvious issues so all that can be wrong MUST be in the sealed electrical box,..

    I open it up and YIKES!! Its flooded with old nasty water

    I pressure washed it off as it was an oily mucky mess& let it dry

    Now i can see to think lol,.. there are a number of components that are likely bad~ here is the list:

    solenoid
    electrical terminal board including two what look to be relays on top of said board
    CDI/ ECU
    lastly ignition coil

    When i say no start i mean NOTHING, not so much as a "click"

    I pulled plugs, lubed cylinders, and ran compression tests, motor is great.. (12vdc direct to starter with jumpers)

    So i have an electrical issue, where do i begin?.. the not even getting a "click" makes me think replace the solenoid first, then (gulp) the CDI?

    Can anyone please help? I bought this just for the trailer, junk the ski/ but its damn nice& i cant do it.. i want to turn this into a river runner one man bass fishing ski..

    Anything you fella can offer is very very good help and thanks!
    Last edited by FishingfromanSL700; 02-19-2021 at 11:51 AM.

  2. #2
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    53
    Posts
    9,522

    Re: Polaris SL700 1996 no start, help?

    SOunds like you are going to need a full electrical box, or at least all internal components.

    I have good, clean start relays, terminal boards, and maybe the LR module.

    I will need numbers off your terminal board, and LR# to be sure. (Start relays are all the same)

    Sorry, I do not have any full boxes, CDI's, wire harnesses or anything else any more for Polaris.

    John
    watcon@watcon.com
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web site

    new parts / products / services www.watcon.com
    thank you

    Please check out and like WATCON on Facebook

  3. #3
    PWCToday Newbie
    Join Date
    Feb 2021
    Location
    Millstadt
    Age
    46
    Posts
    5

    Re: Polaris SL700 1996 no start, help?

    The CDI and coil look to be “sealed”,.. the entire ski is MAYBE worth $1000 in running order so I can’t shotgun parts at it.. but I will get you the part numbers

    I was really looking to replace a component at a time, likely starting with the starting solenoid as it doesn’t look to be sealed

    I will get the numbers later today, the part numbers

    My terminal board cleaned up and dried out quite well,.. are the start relays the ice cube boxes that are plugged into the terminal board?

    Thanks
    Last edited by FishingfromanSL700; 02-20-2021 at 11:54 AM.

  4. #4
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    53
    Posts
    9,522

    Re: Polaris SL700 1996 no start, help?

    Start relay has the battery cables going to it.

    I assume you are talking about the Voltage regulator/rectifier when you say "ice cube boxes" These we call the the "LR" module as they have a "LR" number on them.
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web site

    new parts / products / services www.watcon.com
    thank you

    Please check out and like WATCON on Facebook

  5. #5
    PWCToday Newbie
    Join Date
    Feb 2021
    Location
    Millstadt
    Age
    46
    Posts
    5

    Re: Polaris SL700 1996 no start, help?

    Quote Originally Posted by john zigler View Post
    SOunds like you are going to need a full electrical box, or at least all internal components.

    I have good, clean start relays, terminal boards, and maybe the LR module.

    I will need numbers off your terminal board, and LR# to be sure. (Start relays are all the same)

    Sorry, I do not have any full boxes, CDI's, wire harnesses or anything else any more for Polaris.

    John
    watcon@watcon.com
    LR52-2 (what does this one do?)
    LR21 (same, what does this do?)
    CDI is 105 552.02 (is this sealed?)
    Coil box 105 552.03

    I tested my start solenoid, it is working.. problem is elsewhere

    I tested my start button it is functional

  6. #6
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    53
    Posts
    9,522

    Re: Polaris SL700 1996 no start, help?

    Quote Originally Posted by FishingfromanSL700 View Post
    LR52-2 (what does this one do?)
    LR21 (same, what does this do?)
    CDI is 105 552.02 (is this sealed?)
    Coil box 105 552.03

    I tested my start solenoid, it is working.. problem is elsewhere

    I tested my start button it is functional
    Sorry, I have not worked on Polaris skis for years, and cannot remember what is what. (It is early morning here, and I am not in the shop to look at a shop manual)

    I believe the LR-52 is your voltage regulator.
    I do not remember what the LR21 module is. Trim module maybe?

    I may have these backwards......

    No your CDI is NOT sealed / waterproof.

    There is a TON of info at www.greenhulk.net. Look in the polaris forums, and pinned posts for all the tech info you could ever need. Sounds like you need to do some electrical testing and see where you are loosing power.
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web site

    new parts / products / services www.watcon.com
    thank you

    Please check out and like WATCON on Facebook

  7. #7
    PWCToday Newbie
    Join Date
    Feb 2021
    Location
    Millstadt
    Age
    46
    Posts
    5

    Re: Polaris SL700 1996 no start, help?

    Awesome thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0