Tigershark Montego 640 died, won't start, weak spark
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 5 of 5
  1. #1
    PWCToday Newbie
    Join Date
    Mar 2020
    Location
    Waverly NE
    Posts
    6

    Tigershark Montego 640 died, won't start, weak spark

    Our Tigershark was running great yesterday for it's first time out this season, really since we owned it end of last season. It idled fine, and pulled hard. It would cut and die at high rpm like it was just shut off, and restart fairly easy most times. I chocked it up to a gallon or so of late last seasons gas being mixed with fresh fuel from Tuesday.

    After the first 5 minutes and a couple kills and restarts at high speed, it acted like it was rpm limited and was smokey as crap while at WOT, barely able to make "wake" speed. On my way back to the beach, it suddenly started working fine so we checked it at the beach and took back out for some rips around the lake.

    Parked it for 20 minutes then took my wife out in it. We had it out for another 5-10 minutes and it shut down at WOT. Restarted fine. When we went back to the beach it died idling in the no wake zone and wouldn't restart. We towed it back with our Kawie.

    I checked plugs and they're dark tan for the entire 30 minutes max of runtime they have on them- NGK BPR9ES IX. I gapped them out to .028 since they were a bit tight. I'm getting weak spark according to my inline spark light- looked weaker on mag cylinder. If I dump fuel down the carb it won't act at all like it wants to start. It does the same dumping fuel down spark holes.

    I also looked for a bkown fuse, disconnected the battery and cleaned the cables.

    Checked timing on the flywheel plug and the mag cylinder looks pretty close to TDC around 20* mark.

    Should I try replacing the CDI/coil?

    Will the overtemp sensor prevent starting?

    Any recommendations on what to check or test next? Thanks in advance!!

  2. #2
    PWCToday Newbie
    Join Date
    Mar 2020
    Location
    Waverly NE
    Posts
    6

    Re: Tigershark Montego 640 died, won't start, weak spark

    Also, before we took it out I ground the engagement shaft off the oil pump since I'm running premix with 3oz/gallon. About 50:1. I left all the tubing in place since I didn't have a cap for both the tank and carb.

  3. #3
    PWCToday Newbie
    Join Date
    Mar 2020
    Location
    Waverly NE
    Posts
    6

    Re: Tigershark Montego 640 died, won't start, weak spark

    Just did a compression test and came up with 35-40 psi for both cylinders- they both matched which was odd. Don't have a leakdown tester but when I ran some psi from the compressor into the cylinder I couldn't find an exterior leak.

  4. #4
    PWCToday Newbie
    Join Date
    Mar 2020
    Location
    Waverly NE
    Posts
    6

    Re: Tigershark Montego 640 died, won't start, weak spark

    Tested with oil in cylinders while WOT. Both cylinders are reading 65psi. Is this rings/cylinder or head gasket?

  5. #5
    PWCToday Newbie
    Join Date
    Mar 2020
    Location
    Waverly NE
    Posts
    6

    Re: Tigershark Montego 640 died, won't start, weak spark

    I pulled the head to check the gasket. The gasket and impression look suspect as well as a pretty wet bolt hole on the gasket. It looks like it got some water in there as well as something else bouncing around, unless that was the missing chips on the piston. I thought the plugs looked wet with water when I pulled them.

    I'd imagine this isn't a simple replace the head gasket and take it back out, so I'm planning on replacing the head and doing a top end kit at this point. IMG_20200623_151959.jpgIMG_20200623_152010.jpgIMG_20200623_152133.jpgIMG_20200623_152145.jpgIMG_20200623_152226.jpgIMG_20200623_152349.jpg

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0