cdi for '91 sc
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 4 of 4

Thread: cdi for '91 sc

  1. #1
    PWCToday Regular
    Join Date
    Jul 2018
    Location
    Coastal, NJ
    Posts
    100

    cdi for '91 sc

    Hi, the cdi on my '91 kawasaki sc is not working. Motor still runs but can't shut it off. Have done all tests and it is the cdi. Original part number was 21119-3721. Who carries a replacement for this cdi? It is a 4 wire(2 kills, stator, ground). Thanks.

  2. #2
    Resident Guru sportsfreak29's Avatar
    Join Date
    Oct 2011
    Location
    Oakdale, Ca.
    Posts
    994

    Re: cdi for '91 sc

    I’ve got a couple. Pm me
    If you're not crashing, then you're not trying!!!

    '90 650sx, full mod with all the bells and whistles.
    '84 JS550/650 pump swap with PJS Viper engine.
    '93 550sx with a 650sx motor and Rhass pump kit.
    '81 JS440, full mod 550 PP motor. '
    '93 300sx/750 SP BOB.

    Special thanks to Chris Newmiller, the guys at Prowatercraft Racing, Rhaas Products, and Mitchell at M&M Marine!

  3. #3
    PWCToday Regular
    Join Date
    Jul 2018
    Location
    Coastal, NJ
    Posts
    100

    Re: cdi for '91 sc

    Just sent you a pm. Hope it went through. thanks.

  4. #4
    PWCToday Regular
    Join Date
    Jul 2018
    Location
    Coastal, NJ
    Posts
    100

    Re: cdi for '91 sc

    Picking this thread back up as still having cdi problems. Bought a new aftermarket direct plug in 4 wire cdi. Put it in , no spark. took it out, put my old one back in, ski started right up (but wouldn't shut off as before). figured I had a bad new cdi so sent it back, got another, put 2nd one in, no spark. 4 wires on new cdi are: black with ring terminal(obviously ground), longer red with male connector, and 2 shorter (one black, one blue) with one male and one female connector.People I bought it from said red male is stator and short 2 are 2 kill switches. Makes sense but not working. I am completely frustrated.Any thoughts? Thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0