98 Sportster 1800 one engine suddenly rough - Page 13
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 13 of 13 FirstFirst ... 3111213
Results 121 to 126 of 126
  1. #121
    PWCToday Regular
    Join Date
    Aug 2019
    Location
    Gulf Breeze, FL
    Age
    40
    Posts
    102

    Re: 98 Sportster 1800 one engine suddenly rough

    Also, I have no grounding wire between the two engines as parts diagrams show going from mag cover to mag cover. I plan to add that.

  2. #122
    PWCToday Regular
    Join Date
    Aug 2019
    Location
    Gulf Breeze, FL
    Age
    40
    Posts
    102

    Re: 98 Sportster 1800 one engine suddenly rough

    Quote Originally Posted by HEPHÆSTUS View Post
    I understand what you're saying, but at this point I think I need to keep things as close to stock as possible and not introduce new variables. I rebuilt both my accel pumps just a few weeks ago with new diaphragms, they are confirmed working, and I am not the type to neglect the boat and allow them to gum up and stop working again. The left engine runs great with it so I don't think it's part of my problem. It's just a quick squirt of fuel off idle and that's not where my issues are anyway.

    The part number for my factory carb is BN40-38-28. This does not have a built-in fuel pump. When I punch that into eBay and all the other sites I get either BN40-38-24 or BN40-38-26, both of which look identical to what I have. My understanding is that the last 2 digits indicate venturi size? Would I just get the one closest to what I have in that case? I do not see a single instance of BN40-38-28 available new anywhere on the net, but I also already know that the carbs I have are not the factory carbs, so it's likely they are either -24 or -26 themselves.
    Looking at the current Mikuni catalog, it looks like the only possible applicable carbs still made are BN-40I-38-24 and BN-40I-26.

    It appears that -26 is the MAG carb for dual-carb applications with -27 being the PTO for those same applications. Both have different jetting than the single carb application and what is in mine right now according to this.

    -24 appears to be the single carb application and lists the same jets that I have.

    So it appears that BN-40I-38-24 is my only option and what I guess I will go with. It's probably what I have currently assuming the PO had the same options available to him.
    Last edited by HEPHÆSTUS; 10-08-2019 at 08:31 PM.

  3. #123
    PWCToday Regular
    Join Date
    Aug 2019
    Location
    Gulf Breeze, FL
    Age
    40
    Posts
    102

    Re: 98 Sportster 1800 one engine suddenly rough

    http://osdparts.com/index.php?main_p...oducts_id=7768

    This right here is missing from both my coils. But you wouldn't be able to twist the wires with these. So the wires are just supposed to be pushed in with these on them?

  4. #124
    PWCToday.com Is My Home Away From Home WFO Speedracer's Avatar
    Join Date
    Aug 2006
    Location
    Al-ugh-bam-ugh
    Posts
    26,777

    Re: 98 Sportster 1800 one engine suddenly rough

    yes that's the clip but unless the replacement wire is exactly the same diameter you will never get it back in properly, that why I just epoxy them in after pushing the wire onto the barb inside the coil , Kawasaki and Yamaha epoxy their wires in from the factory
    Y'all know me, still the same O.G. but I been low-key
    hated on by most these &^$$@s with no cheese, no deals and no G's, no wheels and no keys, no boats, no snowmobiles, and no skis, mad at me cause I can finally afford to provide my family with groceries

    I was 300SXing when 300SXing wasn't cool !

  5. #125
    PWCToday Regular
    Join Date
    Aug 2019
    Location
    Gulf Breeze, FL
    Age
    40
    Posts
    102

    Re: 98 Sportster 1800 one engine suddenly rough

    Looking more closely, mine don't appear to have any tabs for those clips so I guess they don't use them.

    I pulled the ignition boxes out of my parts boat and am going to swap one for my right engine. They look to be newer so maybe I'll get some different results with it.

    I found a service tag in the parts boat saying that it keeps blowing the 5 amp fuse. I'm thinking they replaced the entire ignition system in both engines which explains why it all looks brand new. Magneto's, stators, and ignition boxes all look like they were pulled from their boxes yesterday. So those are the mags and stators I used on my new engines.
    Last edited by HEPHÆSTUS; 10-09-2019 at 02:19 PM.

  6. #126
    PWCToday.com Is My Home Away From Home WFO Speedracer's Avatar
    Join Date
    Aug 2006
    Location
    Al-ugh-bam-ugh
    Posts
    26,777

    Re: 98 Sportster 1800 one engine suddenly rough

    I just ran across this this morning after checking on a Kehin jet order I placed a few days ago

    http://www.partsreloaded.com/CLEARAN...tion-Clearance
    Y'all know me, still the same O.G. but I been low-key
    hated on by most these &^$$@s with no cheese, no deals and no G's, no wheels and no keys, no boats, no snowmobiles, and no skis, mad at me cause I can finally afford to provide my family with groceries

    I was 300SXing when 300SXing wasn't cool !

Page 13 of 13 FirstFirst ... 3111213

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0