Possible Charging issue. Strator / Regulator?
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 6 of 6
  1. #1
    PWCToday Newbie
    Join Date
    Jun 2019
    Location
    Freeport, Illinois
    Age
    30
    Posts
    10

    Possible Charging issue. Strator / Regulator?

    I really do appreciate the help guys. Upon starting my 1995 SL 750 today, I noticed that the MFD unit listed 13.5 volts and according to my studies this is low. I’ve studied up and found a sheet stating my ranges should be as follows:

    Red/purple to yellow 0.6 ohms
    white/yellow to black 220 ohms
    Blue/red to white/red 90ohms
    red/white to green/red 490ohms

    from my understanding this is for the 780 but also works with almost all blue Fuji engines. So I would assume it could vary a bit.

    my personal results on my unit are as follows:
    1. Red/purple to yellow started at .6 but climbs to 2.2 over time
    2. Blue/red to red white is about 90-93
    3. White/yellow to black is 234
    4. Red white to green red is 514.

    For what it’s worth it seems I am pretty close to what should be excepted, except for my charging coil / red purple to yellow wire. My question is because I am very new to all this, what could cause this? I am not certain if a high number means bad wire or bad strator.

    On my own little test experiment I tested “alternating current” on my tester and I went from the LR (regulator box) yellow wires along with a ground and that was showing 10-18 volts bouncing in the higher area mostly. When checking the actual battery itself it remains at about 12.5 - despite the mfd stating 13.5 volts.

    Is there a way to test the regulator?

    I really have been reading a ton and found a lot of useful information but I am stumped for now on this one.

    Thank you very much for any thoughts or suggestions.
    Last edited by G25racer; 07-15-2019 at 02:39 PM.

  2. #2
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    54
    Posts
    9,591

    Re: Possible Charging issue. Strator / Regulator?

    13.5 volts should be good. Not sure where you are reading this is low?

    Check your battery voltage while sitting. A fully charged battery should be at or near 12.5v. Now start your machine, you may have to rev it up some. If your voltage climbs, your system is charging and you are good.
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web site

    new parts / products / services www.watcon.com
    thank you

    Please check out and like WATCON on Facebook

  3. #3
    PWCToday Newbie
    Join Date
    Jun 2019
    Location
    Freeport, Illinois
    Age
    30
    Posts
    10

    Re: Possible Charging issue. Strator / Regulator?

    Well the mfd display reads 13.5but actual battery never goes above 12.5.
    I’ve yet to take this to the lake yet, and will probably have to. I’m just doing as many test as possible to avoid having a bad time on lake day lol. I bought this unit as a fixer upper and the guy didn’t state all that was wrong with it. So I’ve been testing everything and this came back as odd. The sheet I found stated the following. 4BDE5449-3A1A-41C9-A9CD-6B9CBFAA7DB0.png

  4. #4
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    54
    Posts
    9,591

    Re: Possible Charging issue. Strator / Regulator?

    Don't think I have EVER seen 14.5 volts on any old PWC charging system while running...…

    13.5 would be fine, and is an increase over 12.5. Our charge systems are weak and do not charge much. (not like a motor cycle running lights, and accessories).
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web site

    new parts / products / services www.watcon.com
    thank you

    Please check out and like WATCON on Facebook

  5. #5
    PWCToday Newbie
    Join Date
    Jun 2019
    Location
    Freeport, Illinois
    Age
    30
    Posts
    10

    Re: Possible Charging issue. Strator / Regulator?

    Quote Originally Posted by john zigler View Post
    Don't think I have EVER seen 14.5 volts on any old PWC charging system while running...

    13.5 would be fine, and is an increase over 12.5. Our charge systems are weak and do not charge much. (not like a motor cycle running lights, and accessories).

    Thanks! Is it normal to see 13.5 on the MFD but only 12.5 on the battery while running?
    I can play around with it a bit more and do further testing on the water, but it just seemed weird to me.

    Thanks!

  6. #6
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    54
    Posts
    9,591

    Re: Possible Charging issue. Strator / Regulator?

    Quote Originally Posted by G25racer View Post
    Thanks! Is it normal to see 13.5 on the MFD but only 12.5 on the battery while running?
    I can play around with it a bit more and do further testing on the water, but it just seemed weird to me.

    Thanks!
    I have not personally ever seen this, but it has been a while since I have had a Polaris in the shop.
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web site

    new parts / products / services www.watcon.com
    thank you

    Please check out and like WATCON on Facebook

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0