94 VXR Pro Starts/Runs Great then Sputters?
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 2 of 2
  1. #1
    PWCToday Newbie
    Join Date
    Jun 2016
    Location
    Mass
    Age
    45
    Posts
    13

    94 VXR Pro Starts/Runs Great then Sputters?

    So I got my 94 VXR Pro finally running after patching a hole and installing a brand new carb. It starts perfect and idles great, I rode it for about 20-25 min on the lake and ran perfect and fast but then I noticed it would start to sputter at full throttle. I also noticed right before that it kind of felt like the throttle cable was starting to stretch even though it wasn't. Any idea what this could be?

    Chris

  2. #2
    PWCToday Newbie
    Join Date
    May 2013
    Location
    alabama
    Age
    61
    Posts
    3

    Re: 94 VXR Pro Starts/Runs Great then Sputters?

    Quote Originally Posted by jester125 View Post
    So I got my 94 VXR Pro finally running after patching a hole and installing a brand new carb. It starts perfect and idles great, I rode it for about 20-25 min on the lake and ran perfect and fast but then I noticed it would start to sputter at full throttle. I also noticed right before that it kind of felt like the throttle cable was starting to stretch even though it wasn't. Any idea what this could be?

    Chris
    My dad had a 94 vxr pro at one time. It would sputter when you tried to open it up. After going through everything It turned out to be the spark plug caps. I used these.

    https://www.ebay.com/itm/MSD-IGNITIO...YAAOSwdDtZtcSu

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0