Help 640 2 stroke No power
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 4 of 4
  1. #1
    PWCToday Newbie
    Join Date
    Jul 2019
    Location
    Dorset
    Posts
    2

    Help 640 2 stroke No power

    Hi I need some help, I have taken my bike out for the first time this year and the bike will idle fine no issues starts fine however it just has no power full throttle goes about 10 mph sometimes if you go in a straight line and sit like that after about 40 seconds it suddenly picks up and you go quickly. Something else I picked up is when I pull a ht lead to see if cuts out you get a little shock but i have checked the leads and they look fine. Im pulling my hair out and not sure where to go from here.

    This is what i have tried;
    1. cleaned carbs
    2. compression test C1 is 120 C2 is 140
    3. changed spark plugs
    C1 doesn't look like it is burning fuel properly when you take the spark plug off :S

    Thank you for your help.

  2. #2
    I dream skis
    Join Date
    Oct 2013
    Location
    Ohio
    Posts
    636

    Re: Help 640 2 stroke No power

    Does it run rough when you go to full throttle and it has no power, then it "cleans up" and runs good after you hold the throttle open for 40 seconds? If this is true, there is something wrong with low speed section of your carbs, and it is running too rich at low speed.
    2, 1998 TS 770 L, restored and running great as of July 2019 (NO THANKS to the person at SBT, who put the WRONG crankshaft bearing into the rebuilt engine I got from them)

  3. #3
    PWCToday Newbie
    Join Date
    Jul 2019
    Location
    Dorset
    Posts
    2

    Re: Help 640 2 stroke No power

    No it will sit sounding fine then all of a sudden will pick up speed. i may add that this doesn't happen all the time and if you take the throttle off while slightly going quickly it will return to slow speeds and wont pick up again.
    it will never bog down what every you dol.

  4. #4
    PWCToday Guru Associated98's Avatar
    Join Date
    May 2014
    Location
    Cottage Grove, MN
    Posts
    301

    Re: Help 640 2 stroke No power

    Sounds like cavitation. Inspect your pump. Probably worn clearances between wear ring and impeller or damaged impeller.
    Own:
    98' TS1000R
    97' Daytona 1000
    97' Daytona 1000
    97' Daytona 1000
    Owned:
    94' Montego (my first) sold
    95' Daytona sold
    95' Daytona parted out
    95' Barracuda sold
    96' Montego sold
    96' Daytona (the one that got away...) sold
    96' Monte Carlo 900 sold
    97' Daytona 1000 clean and beautiful. You will be missed.
    97' Daytona 1000 sold
    99' TS770R sold

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0