Wont Start
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 7 of 7

Thread: Wont Start

  1. #1
    PWCToday Newbie
    Join Date
    Dec 2018
    Location
    NJ
    Age
    32
    Posts
    4

    Wont Start

    Did a five mile run down the river the other day to drop off a jump box to a buddy with a dead battery. Was varying speed 5200, to 6100 rpm messing around on the way down. About a 200yards out my oil light went off, beeping. I shut the ski off, restarted and putted over at 3k to the beach where my pal was without any alarms. Pop off the seat to check oil level, cannot get the top cap off. Its on super tight, like its under pressure or something. I just had it off a few hours before checking level. Cant get it off so im like whatever, gotta get home, fire up the ski and head home. hit 3k rpm again for about a half mile and the ski just shut off. No alarms, no warning just shuts over. Turns over and cranks fine, just wont fire. Get towed back to dock, tow her home, pop off the seat, oil cap comes off with ease. Oil level fine, ski is still just turning over. I dont hear the fuel pump turning on and im not getting spark.

    Main relay? I just replaced it two months ago????? Bad oil pressure switch cause a crank / no start?

    Also, anyone else have problems getting oil cap off right after a ride???

    05 F12x with 120Hours.

    Plugs, oil less then 5 hours.
    Last edited by ho1ywars; 07-05-2019 at 10:51 PM.

  2. #2

    Re: Wont Start

    Check for fault codes.

  3. #3
    PWCToday Newbie
    Join Date
    Dec 2018
    Location
    NJ
    Age
    32
    Posts
    4

    Re: Wont Start

    Alright. Ill do that tonight. I didnt realize it would store a code.

  4. #4
    PWCToday Newbie
    Join Date
    Dec 2018
    Location
    NJ
    Age
    32
    Posts
    4

    Re: Wont Start

    no codes

  5. #5
    I dream skis jlfx car audio's Avatar
    Join Date
    Feb 2011
    Location
    jackson tn
    Age
    39
    Posts
    596

    Re: Wont Start

    Check your fuses ?
    Fuel pump could.be the issue
    05 R12x 142hrs w/ ic upgrade,strait pipe ,stock prop and boost 6380rpm @66.2mph
    09 F15x 39hrs .

  6. #6

    Re: Wont Start

    Not sure it's pressure on the oil cap, mine used to be hard to get off when it was hot, kinda like it would swell up or something so I replaced it and it seems good now.

  7. #7
    PWCToday Newbie
    Join Date
    Dec 2018
    Location
    NJ
    Age
    32
    Posts
    4

    Re: Wont Start

    So i checked fuses the other day. Sure enough the INJ fuse was blown. Started at the injector at the rear of the ski and followed the harness to the front. About six inches after the first injector going forward, the harness was rubbing on a bolt when it turned to the right side of the ski. Wire was bare. Right next to either way I went and pumped out a quart and a half so its at the right level in the oil tank after idling for 2 min.

    Took the ski out yesterday and put 70 miles on it and it ran great for the most part. Only getting 5800 RPM. Didnt have the balls it had before. I had this issue a few rides ago and it fixed itself. Did it my whole trip this time though. It has a new WGA on it. Arm is moving about 8MM When i apply 10PSI. So then I applied VAC to the WGS. I pump it up to 60KPA and it just bleeds off right away right down to about 15KPA. I applied 12v and it opened freely, closed back up and still bled off pressure. So I think I also have a bad WGS. It should hold VAC 100% right????

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0