'94 750 ST - No Spark
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 7 of 7
  1. #1
    PWCToday Newbie chr1s's Avatar
    Join Date
    Aug 2018
    Location
    MA
    Posts
    9

    '94 750 ST - No Spark

    Have not had this boat in the water but it would start and run. Now, no spark. Found ignition coil secondary was open: replaced coil. Still no spark. Stop/lanyard switch is good. Battery is fully charged. Cleaned and verified all connections in electrical box. Resistance checks of stator and magneto are good. Measuring across the magneto leads while running the starter, 8.5 VAC (service manual specs 20 VAC @ 3,000 RPM, so I'm guessing the magneto is working properly).

    My next guess is to replace CDI. Thoughts?
    Last edited by chr1s; 07-04-2019 at 09:59 AM.

  2. #2
    Top Dog Benflynn's Avatar
    Join Date
    Aug 2015
    Location
    Birmingham
    Posts
    1,915

    Re: '94 750 ST - No Spark

    Once everything test good it’s time to suspect cdi

  3. #3
    PWCToday.com Is My Home Away From Home Myself's Avatar
    Join Date
    Jun 2006
    Location
    Arkansas
    Age
    42
    Posts
    5,599

    Re: '94 750 ST - No Spark

    Which colors did you measure from?
    We need pur to red volts
    And blu to grn volts.
    Last edited by Myself; 07-04-2019 at 04:00 PM.
    http://www.facebook.com/twinlakesjetskirepair

    '89 Kawi 650SX 42.4 GPS
    +3" stock pipe, ported ex. manifold, drilled waterbox, blueprinted pump, Ocean Pro ride plate

    '99 Yama GP1200 65U 61.8 GPS
    ported cylinders, matched cases, milled head, blueprinted pump, long ride plate

    '96 Seadoo HX 717 53.13 GPS
    light porting, massaged cases, lightened flywheel, port matched manifolds, Rossier pipe, stubby pump cone

  4. #4
    PWCToday Newbie chr1s's Avatar
    Join Date
    Aug 2018
    Location
    MA
    Posts
    9

    Re: '94 750 ST - No Spark

    I checked resistance on the stator and magneto, and voltage only on the magneto while cranking the starter. I've got a replacement CDI inbound.

  5. #5
    PWCToday Newbie chr1s's Avatar
    Join Date
    Aug 2018
    Location
    MA
    Posts
    9

    Re: '94 750 ST - No Spark

    Replaced CDI. Ignition spark has been restored!

  6. #6
    Top Dog Benflynn's Avatar
    Join Date
    Aug 2015
    Location
    Birmingham
    Posts
    1,915

    Re: '94 750 ST - No Spark

    Nice

  7. #7
    PWCToday.com Is My Home Away From Home Myself's Avatar
    Join Date
    Jun 2006
    Location
    Arkansas
    Age
    42
    Posts
    5,599

    Re: '94 750 ST - No Spark

    Yay!
    http://www.facebook.com/twinlakesjetskirepair

    '89 Kawi 650SX 42.4 GPS
    +3" stock pipe, ported ex. manifold, drilled waterbox, blueprinted pump, Ocean Pro ride plate

    '99 Yama GP1200 65U 61.8 GPS
    ported cylinders, matched cases, milled head, blueprinted pump, long ride plate

    '96 Seadoo HX 717 53.13 GPS
    light porting, massaged cases, lightened flywheel, port matched manifolds, Rossier pipe, stubby pump cone

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0