97 sl700 runs poor. Some times hits a wave and takes off. - Page 2
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    52
    Posts
    8,782

    Re: 97 sl700 runs poor. Some times hits a wave and takes off.

    Quote Originally Posted by pro785 View Post
    Does it have a primer? I have a problem with by backup pro, it does the same thing. But it's been getting worse. If I pull the plugs when it gets like that, two of them are soaked in gas. The primer is working as a venturi and pulling in more fuel through the lines and making it run really rich because the primer pump is not sealing. When the engine revs up, one cylinder firing properly is enough to rev the engine up, causing it to suck in a ton of air and dry the plugs for a little bit. But once I let off the gas it loads back up and won't run right.

    Mine ran decently and now it's gotten far worse. Hopefully I'm right, waiting for my primer pump to show up, should be here tomorrow. As soon as it starts misbehaving like that shut it down and check the plugs immediately and see if they are soaked.

    Does it run right at all? Or is it something that starts going wrong after a little bit?
    Are your primer fittings mounted low, like on the intake manifold? There should not be enough vacuum at the top of the carb to "pull fuel through your primer". I have seen this when people put the primer lines to where oil injection lines where....
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web sites

    new parts / products / services www.watcon.com
    used parts www.rockcountyjetski.webs.com
    thank you

    Please check out and like WATCON on Facebook

  2. #12
    PWCToday Regular
    Join Date
    Aug 2010
    Location
    delavan, wi
    Age
    33
    Posts
    142

    Re: 97 sl700 runs poor. Some times hits a wave and takes off.

    Quote Originally Posted by john zigler View Post
    Are your primer fittings mounted low, like on the intake manifold? There should not be enough vacuum at the top of the carb to "pull fuel through your primer". I have seen this when people put the primer lines to where oil injection lines where....
    Yeah, they're at the top. I think I have an air leak someone in the fuel lines too. If you put an air bubble in between the carb and the primer, when the engine is running you can see the bubble work its way right into the carb. This poor thing sat for a long time and the guy who had it before kind of didn't know what he was doing at all. I'm sure there's multiple things to work out.

    Don't want to hijack the thread, the 700 doesn't have a primer. But there's something wrong with this primer on my boat at the very least. Whether it's the cause or a part of it I don't know, it'll be here today. It needs a new one anyways. It ran fine for a while and it's just getting worse, but it's getting too much fuel from somewhere. When I bypassed the primer it was a bit better.
    90 Superjet, 98 Polaris Pro 785, 95/92 Kawasaki 750 sxi, 01 Polaris 600 sc xp

  3. #13
    PWCToday.com Is My Home Away From Home WFO Speedracer's Avatar
    Join Date
    Aug 2006
    Location
    Al-ugh-bam-ugh
    Posts
    26,539

    Re: 97 sl700 runs poor. Some times hits a wave and takes off.

    Quote Originally Posted by dan.evans View Post
    I have both cylinders firing. Both heads seem about the same temperature. If the stator was bad I should loose spark on one side. It only seems to act up past half throttle.
    Polaris stator issues will drive you to drinking, it truly does act like a carb issue but it's not it's the stator , I went through five on one ski before I got a decent on, all of the original ones were bad, all the ones in the first stator kits were bad, only the third versions were good.
    Y'all know me, still the same O.G. but I been low-key
    hated on by most these &^$$@s with no cheese, no deals and no G's, no wheels and no keys, no boats, no snowmobiles, and no skis, mad at me cause I can finally afford to provide my family with groceries

    I was 300SXing when 300SXing wasn't cool !

  4. #14
    PWCToday Newbie
    Join Date
    Feb 2017
    Location
    PA
    Posts
    1

    Re: 97 sl700 runs poor. Some times hits a wave and takes off.

    compression? needs good compression to pump fuel.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0