Waverunner Water in oil and hull
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 5 of 5
  1. #1
    PWCToday Newbie
    Join Date
    Sep 2009
    Location
    North Carolina
    Age
    70
    Posts
    5

    Waverunner Water in oil and hull

    Help,
    drove my waverunner about 45 minutes no problems. Stopped for about 30 minutes and started again it felt heavy. Started sound different so headed for the lift. Hoisted and took the seat off, hull had almost a foot of water in it so pulled the plugs out to drain it. That water was clean but hot as if it came out of the engine cooling system somewhere? Check the oil tank and found water mixed the oil too. Removed the oil and refilled with fresh oil. Run the engine with the garden hose on it and water still started filling the hull. Replaced oil three more times running the engine about a minute to circulate the oil with no garden hose connected.
    Any ideas from anyone as to how to fix it? Thanks

  2. #2
    I dream skis
    Join Date
    Sep 2002
    Location
    Lake Conroe (Montgomery,) Texas
    Age
    55
    Posts
    550

    Re: Waverunner Water in oil and hull

    Its definitely your cooling system water coming into the hull. When you had it running on the hose, you should have been able to see where the water is leaking. Perhaps it's spraying onto your oil tank?? What ski is it?
    1994 Waveraider, 1997 GP1200
    2 X 1996 Sea Doo XP (sold) ​2013 VXR ​2012 VXS

  3. #3
    PWCToday.com Is My Home Away From Home Grumpy Old Guy's Avatar
    Join Date
    Dec 2003
    Location
    Sunny Fla
    Posts
    25,703

    Re: Waverunner Water in oil and hull

    Quote Originally Posted by sea View Post
    Help,
    drove my waverunner about 45 minutes no problems. Stopped for about 30 minutes and started again it felt heavy. Started sound different so headed for the lift. Hoisted and took the seat off, hull had almost a foot of water in it so pulled the plugs out to drain it. That water was clean but hot as if it came out of the engine cooling system somewhere? Check the oil tank and found water mixed the oil too. Removed the oil and refilled with fresh oil. Run the engine with the garden hose on it and water still started filling the hull. Replaced oil three more times running the engine about a minute to circulate the oil with no garden hose connected.
    Any ideas from anyone as to how to fix it? Thanks
    Year make & model....

  4. #4
    PWCToday Newbie
    Join Date
    Sep 2009
    Location
    North Carolina
    Age
    70
    Posts
    5

    Re: Waverunner Water in oil and hull

    2009 VX Sport. I did buy hardware and installed reverse system and rear step but those are not any factors to the current problem.

  5. #5
    PWCToday Newbie
    Join Date
    Sep 2009
    Location
    North Carolina
    Age
    70
    Posts
    5

    Re: Waverunner Water in oil and hull

    I found the hole in engine case water jacket. Forward most about an inch below the cylinder head to main block parting line. From the staining it looks like a weak porous area that just finally blew out. I could easily plug the water flow with my finger until it got too hot running. I think water got in the oil because of hull flooding through wherever the oil tank breather is while I limped back to the lift. I’m not sure how I can fix this. Ten years old but still runs great. I hate pour $$ in for new engine. I’m thinking of sanding the extended area around the hole and trying JB weld with an aluminum patch. Anyway have any other suggestions?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0