750 sxi turning but not running
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 10 of 10
  1. #1
    PWCToday Regular ryanstandup's Avatar
    Join Date
    Jul 2013
    Location
    SoCal
    Age
    28
    Posts
    61

    750 sxi turning but not running

    Took my sxi into the waves a last month. Accidentally took on some water. Ski wouldnt start on the beach. I took it home and slowly got it started after taking spark plugs out and spraying starter fluid in it and trying to dry it out. Finally got it it to start with new plugs and ran fresh water through it for a while.

    Now I try to start it and it turns and cranks but wont get a full turn over and wont run for more than 5 sec. I am using the choke all the way on when I first try to start it and turn it off after it wont get started. Any help on why it wont start now after I was able to get it to start last month?

    Ive tried the simple things like battery fully charged and new spark plugs but still not luck. Could it be a bad mixture when Im choking it?

    Thanks for the help

  2. #2
    Frequent Poster Kawy750's Avatar
    Join Date
    Jan 2008
    Location
    Connecticut
    Age
    35
    Posts
    214

    Re: 750 sxi turning but not running

    Start simple. Confirm that you have good compression, spark and fuel. Did the motor get hydro locked when you took on water? I’ve heard you can mess up carb diaphragms when that happens. Also never turn the motor over with the plug wires disconnected. This can potentially damage your coil. They should always be grounded to a plug or spark tester. I had an sxi where the stator went bad. Just out of the blue wouldn’t run anymore. Not sure how to test that. You are in the right place. I’ve learned a lot and continue to learn from the help and wisdom on this site.
    08 Superjet
    Limited B pipe, Girdled ADA 35cc, Toby footholds, Riva scoop and stock D cut ride plate.


    87 300sx

    My EX's
    81 440/650
    89 550
    89 650
    96 SXI

  3. #3
    Frequent Poster Kawy750's Avatar
    Join Date
    Jan 2008
    Location
    Connecticut
    Age
    35
    Posts
    214

    Re: 750 sxi turning but not running

    Also. Use starter fluid with moderation if at all. It’s not the best thing for a 2stroke engine. Your better off with a small can of mixed fuel to dribble in the carb if necessary.
    08 Superjet
    Limited B pipe, Girdled ADA 35cc, Toby footholds, Riva scoop and stock D cut ride plate.


    87 300sx

    My EX's
    81 440/650
    89 550
    89 650
    96 SXI

  4. #4
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    52
    Posts
    8,822

    Re: 750 sxi turning but not running

    Could be water in your carbs, fuel tank, electrical box, stator cover, etc. You need to take things apart, clean, and inspect. Also check your reeds. It is not uncommon to bend/break a reed when the engine gets water in it.
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web sites

    new parts / products / services www.watcon.com
    used parts www.rockcountyjetski.webs.com
    thank you

    Please check out and like WATCON on Facebook

  5. #5
    PWCToday Regular ryanstandup's Avatar
    Join Date
    Jul 2013
    Location
    SoCal
    Age
    28
    Posts
    61

    Re: 750 sxi turning but not running

    Put in a carb rebuild kit.... not sure this is what my carbs are supposed to look likeF70D99D2-9CA3-494D-9811-ABBE04C7904A.jpeg

  6. #6
    PWCToday Regular ryanstandup's Avatar
    Join Date
    Jul 2013
    Location
    SoCal
    Age
    28
    Posts
    61

    Re: 750 sxi turning but not running

    Still need to adjust the carb settings. Will my manual say the correct settings?

  7. #7
    Thinks everythng sux =) Top Dog vomitspot's Avatar
    Join Date
    Mar 2005
    Location
    lost
    Age
    45
    Posts
    1,496
    Blog Entries
    1

    Re: 750 sxi turning but not running

    take yhode sbt kits to the trash
    only mikini kits or you will be creating snother problem
    carbs deff need to be cleaned
    nina hagen daz

  8. #8
    PWCToday.com Is My Home Away From Home Chester's Avatar
    Join Date
    Feb 2002
    Location
    Vancouver, BC Canada
    Age
    57
    Posts
    2,984

    Re: 750 sxi turning but not running

    Do not use those carb kits, use only genuine Mikuni kits or you will have problems.

    Chester
    Speed is very expensive. How fast do you want to spend?

    Stand up:
    98 SXi-Pro

    Couches:

    96 XP
    86 X2

  9. #9
    Thinks everythng sux =) Top Dog vomitspot's Avatar
    Join Date
    Mar 2005
    Location
    lost
    Age
    45
    Posts
    1,496
    Blog Entries
    1

    Re: 750 sxi turning but not running

    seen it 1000 times someone wanting to save $1 on cheaper kits only to spend more on getting someone to fix same issue w oem kits
    nina hagen daz

  10. #10
    PWCToday.com Is My Home Away From Home wmazz's Avatar
    Join Date
    Jul 2013
    Location
    Riverside, CA
    Age
    59
    Posts
    2,674
    Blog Entries
    6

    Re: 750 sxi turning but not running

    You need to inspect your gas cap (has it ever been replaced?),
    is the rubber gas cap gasket missing???

    It is more likely that the water inside your carbs came from the
    fuel tank, and not when you sunk the ski.

    You should also drain the tank and mop it clean before you ride
    it again.


    Bill M.

    old post
    Last edited by wmazz; 05-05-2019 at 05:18 PM.
    Horsepower == Speed, RPM != Speed



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0