550sx pump questions...
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 7 of 7
  1. #1
    PWCToday Regular
    Join Date
    Sep 2016
    Location
    Corona/Havasu
    Age
    38
    Posts
    94

    550sx pump questions...

    I'm installing a new prop in my ski and I've ran into a couple of issues. I bought a brand new solas prop from Impros. I've had to use a few thick spacers to get the clearance correct in the pump. So this moved the impeller farther away from the vanes. What does that affect? Also now because the impeller is so much more forward I need to slot the pump mounting bolts and move the pump back about a 1/4 inch so that there is a little free play in the driveshaft. Anyone had to do that before?

    Thanks
    Ryan

  2. #2
    Top Dog Bionic racing's Avatar
    Join Date
    Aug 2016
    Location
    Idaho/California
    Posts
    1,471

    Re: 550sx pump questions...

    Scats fit way better , have had that happen with solas impellors before , moved engine foreword instead , loosen up bed plate bolts and slide foreword

  3. #3
    Frequent Poster SurfSN's Avatar
    Join Date
    May 2014
    Location
    Oregon
    Age
    27
    Posts
    158

    Re: 550sx pump questions...

    Having your impeller too far from the vanes will cause cavitation which could damage your vanes over time from turbulent flow. Plus youll be hurting your pump efficiency and performance. Better to ditch the washers imo

  4. #4
    Top Dog jobrown's Avatar
    Join Date
    May 2009
    Location
    Little Rock, AR
    Age
    31
    Posts
    1,866

    Re: 550sx pump questions...

    Quote Originally Posted by Bionic racing View Post
    Scats fit way better , have had that happen with solas impellors before , moved engine foreword instead , loosen up bed plate bolts and slide foreword
    I ran into the same issues with my 15/20 solas... Mine was so bad I had to add the spacers and move the motor... Ran it like that for around 2 hours and then the impeller unscrewed itself and ground itself down into the pump wall... got the impeller re worked by imros, got a used pump off a guy here, and had zero clearance issues with the new pump and impeller. I don't know if it was the pump that was wore out badly causing the issues or the impeller was sized weird the first time. But the new setup had zero clearance problems.




  5. #5
    PWCToday.com Is My Home Away From Home BLRider's Avatar
    Join Date
    Apr 2007
    Location
    SE MI
    Age
    55
    Posts
    8,725

    Re: 550sx pump questions...

    Waxracing is building stainless pump shoe replacements that could solve this issue if your wear ring is worn or worn out. Should be available soon.
    Never argue with an idiot, they will drag you down to their level then beat you with experience.

  6. #6
    Top Dog
    Join Date
    Oct 2006
    Location
    under a ton of work
    Posts
    1,818

    Re: 550sx pump questions...

    something is not right with the impeller if you have to move it that much forward and notch the case too!
    either that or your wear ring is out of spec!

  7. #7
    PWCToday Regular
    Join Date
    Sep 2016
    Location
    Corona/Havasu
    Age
    38
    Posts
    94

    Re: 550sx pump questions...

    Thanks guys. I agree something isn't right with this prop. It's just weird cause it's a brand new 15/20 solas. I ended up moving the motor forward a little bit and it's good to go now. I guess well see how it turns out...

    Ryan

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0