1996 GTX no spark
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 1 of 3 123 LastLast
Results 1 to 10 of 26
  1. #1
    PWCToday Newbie
    Join Date
    Mar 2018
    Location
    Missouri
    Posts
    24

    1996 GTX no spark

    Picked up a winter project and not getting any spark. Was readibg through a bunch of the other threads and got alot of testing to do. But thinking need to repleace the CDI given looks like was in the box loose, bottom plastic is ate through to circuit board and tops looks like this. 19892.jpeg

  2. #2
    PWCToday.com Is My Home Away From Home Myself's Avatar
    Join Date
    Jun 2006
    Location
    Arkansas
    Age
    42
    Posts
    5,196

    Re: 1996 GTX no spark

    Start with the basics. Make sure voltage does not drop below 11v while cranking. Ohms check the 3 yellow wires for the stator. Less than 1 ohm between any 2 and no continuity from any yellow to ground.
    http://www.facebook.com/twinlakesjetskirepair

    '89 Kawi 650SX 42.4 GPS
    +3" stock pipe, ported ex. manifold, drilled waterbox, blueprinted pump, Ocean Pro ride plate

    '99 Yama GP1200 65U 61.8 GPS
    ported cylinders, matched cases, milled head, blueprinted pump, long ride plate

    '96 Seadoo HX 717 53.13 GPS
    light porting, massaged cases, lightened flywheel, port matched manifolds, Rossier pipe, stubby pump cone

  3. #3
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    51
    Posts
    8,404

    Re: 1996 GTX no spark

    Quote Originally Posted by Myself View Post
    Start with the basics. Make sure voltage does not drop below 11v while cranking. Ohms check the 3 yellow wires for the stator. Less than 1 ohm between any 2 and no continuity from any yellow to ground.
    This, and take the plug boots off, and cut the wires back a 1/4" or so to get into good plug wire.
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web sites

    new parts / products / services www.watcon.com
    used parts www.rockcountyjetski.webs.com
    thank you

    Please check out and like WATCON on Facebook

  4. #4
    PWCToday.com Is My Home Away From Home Grumpy Old Guy's Avatar
    Join Date
    Dec 2003
    Location
    Sunny Fla
    Posts
    25,165

    Re: 1996 GTX no spark

    Start with new MPEM....

  5. #5
    PWCToday Newbie
    Join Date
    Mar 2018
    Location
    Missouri
    Posts
    24

    Re: 1996 GTX no spark

    Thanks ill check all that but figured as burnt as that was it needed replaced regardless. None of the gauges work at all either so got alot of testing to do.

  6. #6
    Frequent Poster daget24's Avatar
    Join Date
    Feb 2013
    Location
    santa barbara
    Age
    27
    Posts
    204

    Re: 1996 GTX no spark

    Quote Originally Posted by grumpy old guy View Post
    start with new mpem....
    x2.
    1 2014 seadoo GTR
    1 1996 seadoo gsx

  7. #7
    PWCToday Newbie
    Join Date
    Mar 2018
    Location
    Missouri
    Posts
    24

    Re: 1996 GTX no spark

    What all years interchange, I know where a complete electrical box is but its from a 96 XP or GSX. Looks same minus the CDI amplifier. Not sure if it was just robbed since looks like pigtail is there. Screenshot_2018-12-16-14-34-02~2.png
    Last edited by cfast; 12-16-2018 at 04:40 PM.

  8. #8
    PWCToday.com Is My Home Away From Home WFO Speedracer's Avatar
    Join Date
    Aug 2006
    Location
    Al-ugh-bam-ugh
    Posts
    26,391

    Re: 1996 GTX no spark

    96 XP and GSX would probably work , you need to double check the MPEM part numbers on some place like Worldofpowersports.com also you can usually type in the OEM Seadoo part number in Google and it will usually direct you to a site that will tell you what that MPEM fits.
    Last edited by WFO Speedracer; 12-16-2018 at 05:29 PM.
    Y'all know me, still the same O.G. but I been low-key
    hated on by most these &^$$@s with no cheese, no deals and no G's, no wheels and no keys, no boats, no snowmobiles, and no skis, mad at me cause I can finally afford to provide my family with groceries


  9. #9
    PWCToday Newbie
    Join Date
    Mar 2018
    Location
    Missouri
    Posts
    24

    Re: 1996 GTX no spark

    Got a new mpem and will get programmed after holidays. Noticed on the wiring going up sreering column the sleeves on all of them even throttle and steering cables have been warm. So assume one of the wires had a short. The dess wiring has been worked on the connector on handllebar side and pins shoved in other side. The two two wore harness seem the worst so want to check them out before putting mpem in. What does the purple and tan or orange with black stripe control. The black ans yellow with red stripe looks like it was prettyy warm as well believe thats the start stop switch. One of the info control center buttons is pushed clear in and doesnt work is that what other wiring controls?
    Last edited by cfast; 12-23-2018 at 12:24 AM.

  10. #10
    PWCToday Newbie
    Join Date
    Mar 2018
    Location
    Missouri
    Posts
    24

    Re: 1996 GTX no spark

    Tore into it a little and the wiring that burnt is for the beeper. The beeper still does work but would the mpem burning like it did cause that wiring to burn? Plan to replace it to avoid having a short causing more issues. It doesnt smell burnt though and since the choke and throttle cable has sone spots that got hot wonder if previous owner had a light or something in machibe when working on it and thats what got everything hot. 1223181119a.jpg

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0