1996 GTX no spark - Page 2
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31
  1. #11
    PWCToday.com Is My Home Away From Home Grumpy Old Guy's Avatar
    Join Date
    Dec 2003
    Location
    Sunny Fla
    Posts
    25,756

    Re: 1996 GTX no spark

    Melted from electrical shorting.

  2. #12
    PWCToday Newbie
    Join Date
    Mar 2018
    Location
    Missouri
    Posts
    30

    Re: 1996 GTX no spark

    Thanks I wasnt sure. Maybe thats wby bepper isnt always consistent when hooking up dess

  3. #13
    PWCToday.com Is My Home Away From Home Grumpy Old Guy's Avatar
    Join Date
    Dec 2003
    Location
    Sunny Fla
    Posts
    25,756

    Re: 1996 GTX no spark

    Quote Originally Posted by cfast View Post
    Thanks I wasnt sure. Maybe thats wby bepper isnt always consistent when hooking up dess
    Thats normal...

    Sad but true.

  4. #14
    PWCToday Regular
    Join Date
    May 2009
    Location
    the 'ville, kentucky
    Age
    75
    Posts
    118

    Re: 1996 GTX no spark

    my beeper never has worked

  5. #15
    PWCToday Newbie
    Join Date
    Mar 2018
    Location
    Missouri
    Posts
    30

    Re: 1996 GTX no spark

    Havent gotten new mpem programmed yet since may buy another and want keys to match. The wife has been complaining of gas smell so decided to check out the fuel lines. I cleaned the inside of hull thinking was just leftover from previous owner working on and then found the gas tank wasnt venting. Previous owner had changed out fuel lines but tried to bypass the fuel selector. He had the vent just looped back to return, pulling fuel from on and returning to reserve all on the sending unit.

    I got some gates fuel hose on order and just gonna replace what they had done already. Pretty sure right but feed for carbs is the back line that splits to both carbs and the return just on front carb. Also should feed line run under carbs and around are over top?

    Also the previous owner tied both vents to the oil tank, should this be vented if so where is proper place?
    0109191744.jpg

    Also noticed alot of white powder sitting in top of carbs and these three Allen head bolts are completly full. Anyone seen anything like this and is it something to worry about?
    0109191742.jpg
    0109191743.jpg

  6. #16
    PWCToday Newbie
    Join Date
    Mar 2018
    Location
    Missouri
    Posts
    30

    Re: 1996 GTX no spark

    Just wanted to double check now that shorted wires replaced and I can get spark with the mpem that has melted so thats good. Hopefully getting fuel lines in right place will fix rest of problem.

  7. #17
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    52
    Posts
    8,878

    Re: 1996 GTX no spark

    Both fuel and oil tank NEED to be vented.

    Fuel tank sending unit is marked with "Vent, RET, ON, and RES"

    Your white powder looks like corrosion. Not uncommon on a ski that is stored wet.
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web site

    new parts / products / services www.watcon.com
    thank you

    Please check out and like WATCON on Facebook

  8. #18
    PWCToday Newbie
    Join Date
    Mar 2018
    Location
    Missouri
    Posts
    30

    Re: 1996 GTX no spark

    The oil tank just vents right on top of tank though right? He had it tied to the tee for fuel line venting.

    Figured would clean the rave valves as well since who onows when was done before if ever. It has the original red bellows at this age should they be replaced or just clean up and new orings.

    Also plan to drain oil tank and replace filter, and small oil lines since still factory. Plan to run mystic full synthetic.

  9. #19
    PWCToday.com Is My Home Away From Home WFO Speedracer's Avatar
    Join Date
    Aug 2006
    Location
    Al-ugh-bam-ugh
    Posts
    26,707

    Re: 1996 GTX no spark

    No the fuel inlet is on the front carb , return is off of the rear carb on the hose that splits and goes to both carbs
    Y'all know me, still the same O.G. but I been low-key
    hated on by most these &^$$@s with no cheese, no deals and no G's, no wheels and no keys, no boats, no snowmobiles, and no skis, mad at me cause I can finally afford to provide my family with groceries

    I was 300SXing when 300SXing wasn't cool !

  10. #20
    PWCToday Newbie
    Join Date
    Mar 2018
    Location
    Missouri
    Posts
    30

    Re: 1996 GTX no spark

    Thanks will get that fixed once new hose and clamps come in.

Page 2 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0