Kawasaki trim motor only goes down
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 3 of 3
  1. #1
    PWCToday Newbie
    Join Date
    Jul 2018
    Location
    VA
    Age
    34
    Posts
    18

    Kawasaki trim motor only goes down

    I have a '98 stx 900. I have taken all the trim components out from the housing so the motor, controller, angle indicator all sit outside the housing now. With the main motor running only the down switch will start the trim motor, up switch does nothing regardless of where I place the angle indicator. Angle indicator works fine if I move to lowest position it stop the motor from turning when the dowswitch is pushed. Also removed angle indicator and it did the same thing, down switch moves the motor, up switch does nothing. Checked it with a multimeter 12v down nothing up. Checked the b/w wire against g/w wire (up from harness) I have continuety when they are pushed from switch. What else could it be?

  2. #2
    PWCToday Newbie
    Join Date
    Jul 2018
    Location
    VA
    Age
    34
    Posts
    18

    Re: Kawasaki trim motor only goes down

    I've already tried another controller also. Same thing.

  3. #3
    PWCToday Newbie
    Join Date
    Jul 2018
    Location
    VA
    Age
    34
    Posts
    18

    Re: Kawasaki trim motor only goes down

    I have a service manual and it states that the majority of probs are in the ignitor. But it looks like the trim switch goes to the reverse handle then to trim controller. Is that correct?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0