Starting issue 2008 150 seadoo speedster
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 5 of 5
  1. #1
    Resident Guru Mackzilla's Avatar
    Join Date
    Feb 2007
    Location
    Douglas , Ga.
    Age
    56
    Posts
    860

    Starting issue 2008 150 seadoo speedster

    This is a 2008 Seadoo speedster with single 4tec 215 SC engine. I just pulled the engine to clean out all the washer pieces from a blown clutch pack on the SC. Engine is back in craft everything hooked back up but when I plug the key in im getting a buzzing noise from a relay that works the starter solenoid. I changed the relay and still making the buzzing noise and will not turn over??? Anyone run into this with any seadoos ?? Also im getting no beeps when key gets plugged in...….
    Last edited by Mackzilla; 11-19-2018 at 06:24 PM. Reason: added to post
    MACKZILLA JETUNLIMITED

  2. #2
    Resident Guru Mackzilla's Avatar
    Join Date
    Feb 2007
    Location
    Douglas , Ga.
    Age
    56
    Posts
    860

    Re: Starting issue 2008 150 seadoo speedster

    ive noticed in these posts whenever someone mentions a dess problem or beep issues there are no replies. this must be a sore subject !
    MACKZILLA JETUNLIMITED

  3. #3
    PWCToday.com Is My Home Away From Home Myself's Avatar
    Join Date
    Jun 2006
    Location
    Arkansas
    Age
    42
    Posts
    5,194

    Re: Starting issue 2008 150 seadoo speedster

    You sure you got all the grounds back tight?
    http://www.facebook.com/twinlakesjetskirepair

    '89 Kawi 650SX 42.4 GPS
    +3" stock pipe, ported ex. manifold, drilled waterbox, blueprinted pump, Ocean Pro ride plate

    '99 Yama GP1200 65U 61.8 GPS
    ported cylinders, matched cases, milled head, blueprinted pump, long ride plate

    '96 Seadoo HX 717 53.13 GPS
    light porting, massaged cases, lightened flywheel, port matched manifolds, Rossier pipe, stubby pump cone

  4. #4
    Resident Guru Mackzilla's Avatar
    Join Date
    Feb 2007
    Location
    Douglas , Ga.
    Age
    56
    Posts
    860

    Re: Starting issue 2008 150 seadoo speedster

    you are exactly right my friend ! I read this and went and checked over the entire engine with a flashlight and found a group of 5 grounds in very front of engine that was left ungrounded. put those on and fixed the issue ! Thank you for the suggestion , sometimes that's all it takes to set someone on the right path !
    MACKZILLA JETUNLIMITED

  5. #5
    PWCToday.com Is My Home Away From Home Myself's Avatar
    Join Date
    Jun 2006
    Location
    Arkansas
    Age
    42
    Posts
    5,194

    Re: Starting issue 2008 150 seadoo speedster

    Yay! I like the simple fixes.
    http://www.facebook.com/twinlakesjetskirepair

    '89 Kawi 650SX 42.4 GPS
    +3" stock pipe, ported ex. manifold, drilled waterbox, blueprinted pump, Ocean Pro ride plate

    '99 Yama GP1200 65U 61.8 GPS
    ported cylinders, matched cases, milled head, blueprinted pump, long ride plate

    '96 Seadoo HX 717 53.13 GPS
    light porting, massaged cases, lightened flywheel, port matched manifolds, Rossier pipe, stubby pump cone

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0