Kawasaki 1100 stx d fuel pumpi mystery - Page 2
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    fly over country
    Posts
    10

    Re: Kawasaki 1100 stx d fuel pumpi mystery

    So, rooted around in shed and found a bag of Bosch 5 pin relays. Found a 4 pin but its Chinese and I think the Bosch are better.
    Plan to wire the new pump through the relay with the ground being made in the emm when the relay is powered. Hopefully this will trick the emm into not sensing the true load of the aftermarket pump. Would like to power the relay from the stock harness wire that powers the pump so the shutoff lanyard works. Well that's the plan anyway. Dunno if it will work or not.

  2. #12
    PWCToday Newbie
    Join Date
    Jul 2010
    Location
    Ireland
    Age
    46
    Posts
    5

    Re: Kawasaki 1100 stx d fuel pumpi mystery

    Hey
    Did you get your fuel pump issue sorted I seem to have a similar issue after fitting an after market Fuel PUMP

  3. #13
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    fly over country
    Posts
    10

    Re: Kawasaki 1100 stx d fuel pumpi mystery

    I did not finish the job. The weather turned to crap...snow and cold and all that and the job got put on the back burner till spring. I do believe using the relay will work.

  4. #14
    Resident Guru
    Join Date
    Jan 2012
    Location
    Georgia
    Age
    37
    Posts
    931

    Re: Kawasaki 1100 stx d fuel pumpi mystery

    I have done this on a couple of DI polaris boats. The Polaris EMM is VERY picky with regard to pump amperage.

    I use this type of bosch relay:

    https://www.amazon.com/PACK-AMP-Wate...gateway&sr=8-6

    I get an OEM one, not the Chinese one. The link is just to show you the setup. The chinese connector seems fine.
    XI Sport
    GP800R
    X2
    FX140

  5. #15
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    fly over country
    Posts
    10

    Re: Kawasaki 1100 stx d fuel pumpi mystery

    So finally had time to work on the science experiment. wired up the aftermarket pump using a relay and added a second deadman in the harness. The thing starts and runs. Took it to the river today (read mistake) big mistake. Had not ever ridden a PWC before so wasn't sure what to expect. Snowmobile on water ? Anyway it putted around ok and had some red lamps and ck engine stuff. Fuel level sender wasn't working but a crack of the throttle and it jumped up and off it went. Ran great, until it didn't. Of course by that time I was a mile upstream.. Best it would do was 3mph at about 3500rpm. Any more throttle than that acted like a slipping clutch. So rather than swim, I motored back to the ramp at 3mph. By the time I got to the ramp I was on a submarine, hull about half full of water. Drug the thing out opened the plugs and drained the water. Also removed a basketball, make that 2, sized clump of river grass from the intake. So my question is this. Do I have two separate problems or did/can the river grass clogging the intake cause water to be ingested into the hull ?
    Don't see any holes in the hull and water didn't pour out anywhere when I pulled it out. Haven't checked yet to see if the engine is pumping cooling water into the hull. Both of these things seemed to happen at the same time and I am wondering if the slow trip back to the ramp caused the water intake somehow. Maybe time for a bilge pump.

  6. #16
    PWCToday Newbie
    Join Date
    Jul 2018
    Location
    Michigan
    Posts
    20

    Re: Kawasaki 1100 stx d fuel pumpi mystery

    Defenitly sounds like 2 separate issues. I have sucked in lots of weeds before and it has never caused the ski to fill with water. Start looking at loose cooling lines or worn drive shaft through hull seal.

    Sent from my SM-G960W using Tapatalk

  7. #17
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    fly over country
    Posts
    10

    Re: Kawasaki 1100 stx d fuel pumpi mystery

    So definetly two different issues. Found a hole in the bottom of the "body muffler" or expansion chamber, whatever its called. There are two casting lugs on the bottom and the one near the 90 fitting was eaten through.
    Gonna have to see if its weldable. Thought I could tap and plug it but inner wall is too close.

  8. #18
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    fly over country
    Posts
    10

    Re: Kawasaki 1100 stx d fuel pumpi mystery

    Managed to get a 1/4" pipe plug to thread into the casting boss and plug the hole. Covered it with JB Weld. Here's hoping it stays put.
    Can anyone tell me where the 1/2" hose that goes on the fitting on the bottom of this muffler exits. It runs to the back and disappears into a maze of tubes. All the diagrams I have seen say it goes to a hull outlet. Where is that ?

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0