2003 xp-di - Page 3
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: 2003 xp-di

  1. #21
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    image.jpgOk so i removed it and beach testing now th be sure itís not the wiring from the handle bar to mpem

  2. #22
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    Black to outer ring - Continuity
    White to center post - continuity
    Black to black/yellow - continuity with key
    black to black/purple - continuity with key

    What other test should happen

  3. #23
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    I am wondering if 2/20 wire is broken in machine since that didn’t seem to have continuity on either pin at mpem

  4. #24
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    Quote Originally Posted by 1957Dave View Post
    OK try this, first back probe 2/12 to battery ground, should have continuity, remove connector 2 ,with key on check 2/12 to either 2/15 or 2/23 should have continuity on one of them, next check 2/20 to either 2/15 or 2/23 should be on the opposite , if that's OK DESS is working, that triggers MEPM to send voltage on 3/9 to pull relay down and send power back on 3/25
    did you mean 2/20 to 2/12 and not 15 or 23? I believe your test doesnít lineup with what the DESS is doing on the bench

  5. #25
    Frequent Poster
    Join Date
    Aug 2012
    Location
    whitby ont canada
    Age
    61
    Posts
    167

    Re: 2003 xp-di

    sorry yes, check 2/20 back to MPEM

  6. #26
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    Quote Originally Posted by 1957Dave View Post
    sorry yes, check 2/20 back to MPEM
    Will do, since it appears my DESS is working if 2/20 is good what would be the next step? Could it be a ground somewhere or is my MPEM shot?

  7. #27
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    double post sorry
    Last edited by turbosl2; 10-11-2018 at 09:14 AM.

  8. #28
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    Quote Originally Posted by 1957Dave View Post
    sorry yes, check 2/20 back to MPEM
    Dave thanks for the help so far. Could you help me with the principal on how the DESS and MPEM trigger the cut off relay. I am lost as to why when i test my DESS on the bench the 2/12 2/20 and 2/23 all have continuity. Is there not a 12V signal that is suppose to come into here or is it suppose to bridge all these to ground?

    If you could help with what wires are supposed to have voltage and when coming out of the MPEM (particularly 2/12, 2/15, 2/20, 2/23 and how that affects 3/9 and 3/25 i could diagnose this better. Anything you know on the principal of operation would help.

    THanks

  9. #29
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    B906F9E6-72DE-47C9-BD04-B307B3A47F7A.jpeg
    Problem fixed. Wire at ecu was cooreded and was not making contact.
    Thanks guys!
    Attached Images Attached Images

  10. #30
    Frequent Poster mrwhipper's Avatar
    Join Date
    May 2017
    Location
    New Holland
    Posts
    217

    Re: 2003 xp-di

    GREAT news! I am glad that you found it!

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0