2003 xp-di - Page 2
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30

Thread: 2003 xp-di

  1. #11
    Frequent Poster mrwhipper's Avatar
    Join Date
    May 2017
    Location
    New Holland
    Posts
    217

    Re: 2003 xp-di

    Quote Originally Posted by turbosl2 View Post
    Ok that will be my plan tonight. My assumption is the wires were cut to wire in the new relay when he realized he bought a 4 wire relay vs a 3, then stopped
    That is what I was guessing but I did not want to say it and take you down a wrong path.

  2. #12
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    I am pretty sure it won’t power up after I wire on the original relay because he cut it out for a reason. And the new one is 4 wire

  3. #13
    Frequent Poster
    Join Date
    Aug 2012
    Location
    whitby ont canada
    Age
    61
    Posts
    167

    Re: 2003 xp-di

    Dess posts are known bad on those boats , he may have been trying to get the relay to power up not knowing the dess post was the problem, test the relay, also bad grounds to engine made me chase my tail until I corrected them, ground OK at the bottom of the block near starter but no ground above barrels or at head

  4. #14
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    image.jpg
    Quote Originally Posted by 1957Dave View Post
    Dess posts are known bad on those boats , he may have been trying to get the relay to power up not knowing the dess post was the problem, test the relay, also bad grounds to engine made me chase my tail until I corrected them, ground OK at the bottom of the block near starter but no ground above barrels or at head
    Hmm well I canít find any ground visible to my eye. Lol. If I short the starter relay she cranks. If I apply power to the black wire with purple stripe at the cutoff relay to energize it, she will boot up gauges, beep and starter button will crank her. It will also recognize the key is in cause of 2 beeps. Just nothing happens when you remove the key and reinsert it without the cutoff relay manually energized. DESS post not recognizing key is inserted and bad?

    See wiring photo circled in red

  5. #15
    Frequent Poster
    Join Date
    Aug 2012
    Location
    whitby ont canada
    Age
    61
    Posts
    167

    Re: 2003 xp-di

    OK try this, first back probe 2/12 to battery ground, should have continuity, remove connector 2 ,with key on check 2/12 to either 2/15 or 2/23 should have continuity on one of them, next check 2/20 to either 2/15 or 2/23 should be on the opposite , if that's OK DESS is working, that triggers MEPM to send voltage on 3/9 to pull relay down and send power back on 3/25

  6. #16
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    Thanks Dave will try this tonight, I should unplug this connection at the MPEM and prob the connector?

  7. #17
    Frequent Poster
    Join Date
    Aug 2012
    Location
    whitby ont canada
    Age
    61
    Posts
    167

    Re: 2003 xp-di

    back probe 2/12 with connector on then remove for dess test and probe connector

  8. #18
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    Quote Originally Posted by 1957Dave View Post
    back probe 2/12 with connector on then remove for dess test and probe connector
    Will do and report back.

  9. #19
    PWCToday Newbie
    Join Date
    Oct 2018
    Location
    NY
    Posts
    30

    Re: 2003 xp-di

    Quote Originally Posted by 1957Dave View Post
    OK try this, first back probe 2/12 to battery ground, should have continuity, remove connector 2 ,with key on check 2/12 to either 2/15 or 2/23 should have continuity on one of them, next check 2/20 to either 2/15 or 2/23 should be on the opposite , if that's OK DESS is working, that triggers MEPM to send voltage on 3/9 to pull relay down and send power back on 3/25
    first part checks out with key on but nothing from 2/20 to 2/15 or 2/20 to 2/23 key on or not. No continuity

  10. #20
    Frequent Poster
    Join Date
    Aug 2012
    Location
    whitby ont canada
    Age
    61
    Posts
    167

    Re: 2003 xp-di

    Dess failed

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0