1995 Wave Venture - No electrical power
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 6 of 6
  1. #1
    PWCToday Newbie
    Join Date
    Jan 2014
    Location
    Temecula
    Age
    43
    Posts
    46

    1995 Wave Venture - No electrical power

    Hello everyone, I have owned for 5+ years a 1995 Wave Venture 700, 140hrs on the engine, the most reliable piece of machinery ever built by human hands.. until last night. Yesterday we rode all day with no problems, at the end of the day when loading it on the trailer I lost all electrical power. On these boats the display only lights up after cranking the starter, so no crank and no display. Dead. Today in the morning I try again and it starts like a champ and purrs like a kitten, display is all good. I didn't do or touch anything. Maybe the start/kill switch is going to junk heaven? I've heard the plates and springs inside the switch corrode with time. If anyone has experienced this I appreciate your comments. Thanks much.

  2. #2
    PWCToday.com Is My Home Away From Home JSNate's Avatar
    Join Date
    Apr 2010
    Location
    Michigan
    Age
    55
    Posts
    4,052

    Re: 1995 Wave Venture - No electrical power

    Check all battery/ground and electrical connections first.. If that is not an issue, then you may have a start/stop switch starting to fail. The start/stop is a weak spot on Yamaha PWC. Also, the starter solenoid may be going bad as well. All of these are easy fixes.
    Last edited by JSNate; 09-17-2018 at 03:41 PM.

  3. #3
    PWCToday Newbie
    Join Date
    Jan 2014
    Location
    Temecula
    Age
    43
    Posts
    46

    Re: 1995 Wave Venture - No electrical power

    Quote Originally Posted by JSNate View Post
    Check all battery/ground and electrical connections first.. If that is not an issue, then you may have a start/stop switch starting to fail. The start/stop is a weak spot on Yamaha PWC. Also, the starter solenoid may be going bad as well. All of these are easy fixes.
    Thanks for your relpy JSNate. The starter solenoid is inside the electrical box?

  4. #4
    PWCToday.com Is My Home Away From Home JSNate's Avatar
    Join Date
    Apr 2010
    Location
    Michigan
    Age
    55
    Posts
    4,052

    Re: 1995 Wave Venture - No electrical power

    Quote Originally Posted by cgonzal1 View Post
    Thanks for your relpy JSNate. The starter solenoid is inside the electrical box?
    Yes.. Round and easy to identify. From my experience, they tend to have a few failures before they die for good.

  5. #5
    PWCToday.com Is My Home Away From Home JSNate's Avatar
    Join Date
    Apr 2010
    Location
    Michigan
    Age
    55
    Posts
    4,052

    Re: 1995 Wave Venture - No electrical power

    If this happens again, it is easy to check if it's the solenoid.. Just open the ebox and jump the contacts.. If the starter engages, replace the solenoid.

  6. #6
    PWCToday Newbie
    Join Date
    Jan 2014
    Location
    Temecula
    Age
    43
    Posts
    46

    Re: 1995 Wave Venture - No electrical power

    Quote Originally Posted by JSNate View Post
    If this happens again, it is easy to check if it's the solenoid.. Just open the ebox and jump the contacts.. If the starter engages, replace the solenoid.
    Got it. Thank you for the great advice.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0