pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 7 of 7
  1. #1
    PWCToday Newbie
    Join Date
    Jul 2018
    Location
    Benton, La
    Posts
    20

    Strange feeling on XL800

    I have a 2001 800XL...when punching it to full throttle like when starting from a stop, or coming out of a spin, it feels as if it only sucking air! Kind of like when a boat prop catches air, or a transmission that slips sort of feeling and sound.

    Is this normal?

  2. #2
    PWCToday Newbie Raggums's Avatar
    Join Date
    Jun 2018
    Location
    Northern Ontario
    Posts
    12

    Re: Strange feeling on XL800

    That is cavitation and there are several possibilities for it. Bad wear ring and/or damaged impeller or could be something with the intake grate not allowing enough water in to the pump. Check your pump for damage to the wear ring and impeller and get underneath and check our intake.

  3. #3
    PWCToday Newbie
    Join Date
    Jul 2018
    Location
    Benton, La
    Posts
    20

    Re: Strange feeling on XL800

    That's the word that was at the tip of my tongue!

    I know nothing about working on these things...where is the best place for a service manual?

  4. #4
    PWCToday Newbie Raggums's Avatar
    Join Date
    Jun 2018
    Location
    Northern Ontario
    Posts
    12

  5. #5
    PWCToday Newbie Raggums's Avatar
    Join Date
    Jun 2018
    Location
    Northern Ontario
    Posts
    12

    Re: Strange feeling on XL800

    Crap sorry, just the user manual, my bad

  6. #6
    PWCToday Newbie
    Join Date
    Jul 2018
    Location
    Benton, La
    Posts
    20

    Re: Strange feeling on XL800

    Is there a pump seal kit for this ski? I found one for the XLT, but also read there is not one for the XL 800, only the 1200.

  7. #7
    PWCToday Newbie Raggums's Avatar
    Join Date
    Jun 2018
    Location
    Northern Ontario
    Posts
    12

    Re: Strange feeling on XL800

    I don't see one on the parts microfiche for your model.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0