pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 5 of 5
  1. #1
    PWCToday Newbie
    Join Date
    Jul 2018
    Location
    Dallas. PA
    Age
    54
    Posts
    18

    Just had to skis given to me . . . where to start.

    Hello all . . .

    I am new to PWC's but not new with boats, engines or tinkering. I had two skis and a trailer given to me this weekend. One is a 99 Kawasaki 1100 STX and the other is a 95 Seadoo GTI. The trailer is road ready. The 1100 had a new motor put in it and the owner did not get it dialed in. He said it runs and starts well, but after a bit on the water, it won't go faster than a few miles per hour. It is not overheating. His diagnosis was a bad sensor or computer. The Seadoo supposedly runs fine as-is but has a leak around the shaft.

    Neither of these have seen the water since 2012. They were prepped for winter and untouched since because the owner lost interest. I have put many cars back on the road after long lay ups, and the usual procedure is to drain all fluids and replace. Replace any rubber hoses or seals. Drain the fuel and clean the tank etc.


    Any tips you can provide to get me started would be most helpful. I am in Northeast PA now, but will be taking these to Indian River Bay in Delaware. We have a cottage there and they will stay in DE once they are running properly.

    Thanks for advice and tips you can offer!
    IMG_0607.jpgIMG_0608.jpgIMG_0609.jpgIMG_0610.jpg
    Last edited by Stonedbeetle; 07-16-2018 at 08:00 PM.

  2. #2
    PWCToday Newbie
    Join Date
    Jul 2018
    Location
    Crawfordville FL
    Posts
    37

    Re: Just had to skis given to me . . . where to start.

    First off, what a great free pickup you got there. Sounds like both issues are minor and you should be gtg with a little bit of tinkering!

  3. #3
    PWCToday.com Is My Home Away From Home Cliff's Avatar
    Join Date
    Jun 2011
    Location
    Where I can see the air I breathe...
    Posts
    3,881

    Re: Just had to skis given to me . . . where to start.

    Quote Originally Posted by Stonedbeetle View Post
    Hello all . . .

    I am new to PWC's but not new with boats, engines or tinkering. I had two skis and a trailer given to me this weekend. One is a 99 Kawasaki 1100 STX and the other is a 95 Seadoo GTI. The trailer is road ready. The 1100 had a new motor put in it and the owner did not get it dialed in. He said it runs and starts well, but after a bit on the water, it won't go faster than a few miles per hour. It is not overheating. His diagnosis was a bad sensor or computer. The Seadoo supposedly runs fine as-is but has a leak around the shaft.

    Neither of these have seen the water since 2012. They were prepped for winter and untouched since because the owner lost interest. I have put many cars back on the road after long lay ups, and the usual procedure is to drain all fluids and replace. Replace any rubber hoses or seals. Drain the fuel and clean the tank etc.


    Any tips you can provide to get me started would be most helpful. I am in Northeast PA now, but will be taking these to Indian River Bay in Delaware. We have a cottage there and they will stay in DE once they are running properly.

    Thanks for advice and tips you can offer!
    IMG_0607.jpgIMG_0608.jpgIMG_0609.jpgIMG_0610.jpg
    Welcome to the party!

    I don't know about Kawi's. But I a little something about Sea Doo watercraft and I know for certain that is a '96 GTi with the 717cc motor and not a '95 model. It also appears to have the touring seat which allows the passenger a view from the back due to the "stadium seating" configuration. The motor should have a cold cranking compression of 150 psi in each cylinder and that leak coming from the drive shaft is coming from the carbon ring seal with the bellow(accordion hose) and two worm gear clamps attached to it. It's most likely worn out and needs to be replaced. Doesn't take much to repair. Check the fuel lines and change all of them if the fuel lines are grey and say "Tempo" on them. You'll need about 25' of fuel line and clamps to complete this repair. Check the impeller for dings to the edges of the blades. You'll need to send it out for repair if damage is present. Check the jet pump oil in the cone attached to the middle of the jet pump. The oil will most likely need to be changed. Check the wear ring clearance between the edge of the impeller and the wear ring in the jet pump. This clearance is important and should be LESS than 1mm. Yes. One(1) mm for proper pressurization of the pump for forward propulsion or it will feel like your not really going anywhere when you pin the throttle. Carbs will probably need to be rebuilt as it will have gum and varnish inside of them due to the ski sitting for so long without it being started and ran with the gas knob turned off to burn off the excess fuel in the carbs. They might also have some rust in the carbs that will need to be cleaned out. Check all the nuts and bolts for tightness like the intake grate, steering system base bolts/nuts etc. There are other items to check like the reverse and steering cable and other items as well. But this list should keep you busy for a little while because you don't want to be stranded out on the water!

    Download the factory manual and start reading up on it. Lots of info and it will get you started in the right direction.

    Here is where I get most of my OEM parts(you just need to know the part number):

    http://osdparts.com
    Last edited by Cliff; 07-17-2018 at 12:23 AM.
    What would Chuck Norris do?

  4. #4
    PWCToday Newbie
    Join Date
    Jul 2018
    Location
    Dallas. PA
    Age
    54
    Posts
    18

    Re: Just had to skis given to me . . . where to start.

    Thanks for the great info Cliff. Exactly what I was looking for. I figure I will go through these steps and that should get me running. We will see where we stand then. Also, you are correct. It is a 96. I typed that all wrong.

  5. #5
    PWCToday Newbie
    Join Date
    May 2018
    Location
    TX
    Posts
    32

    Re: Just had to skis given to me . . . where to start.

    Wow. Great Info!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0