2001 gtx maint light and limp mode
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 4 of 4
  1. #1
    PWCToday Newbie
    Join Date
    Jul 2018
    Location
    Tyler
    Posts
    2

    2001 gtx maint light and limp mode

    Good afternoon - I have been searching for the fix for my issue, but not quite finding one going in the right direction.

    I have two 01' GTX models and I went to take them out this weekend, and one had a dead battery when I went to start them. I put a charger on the battery on high charge, and then started it after 10 minutes or so. When it started up it idles just fine, but blinks the red maint light, and has blinking maint on the display as well as it will only rev up a little.

    After reading MANY threads, I have replaced the battery, and replaced the plugs. Then with my volt meter I tested the rectifier and the leads coming from them show 11-12 and when starting it, it seems the same. I then took the rectifier out of the other ski (which is working fine) and put it on this ski, and still same error messages. I then checked the voltage with what I am pretty sure is coming from the stator to the rectifier and they show the same current and does not seem to change when its started. I then did the same process on the good ski with the exact same results.

    I went ahead and checked compression as well, and on the ski with warning lights, it is 145, 130. On the good ski I show 130,130

    So I feel I am now stumped!! My other option now is to take it to local dealer to run diagnostics for $120. Only issue is this shop fried a motor on my kawa last year and I had to rebuild the motor, so I REALLY hate to give them any money at all, but they are the only place within an hour..

    So any advice or ideas are GREATLY appreciated from the experts on this site!!

    Thanks in advance.
    Brian

  2. #2
    PWCToday.com Is My Home Away From Home Grumpy Old Guy's Avatar
    Join Date
    Dec 2003
    Location
    Sunny Fla
    Posts
    24,992

    Re: 2001 gtx maint light and limp mode

    Could be a blown fuse....

  3. #3
    PWCToday Newbie
    Join Date
    Jul 2018
    Location
    Tyler
    Posts
    2

    Re: 2001 gtx maint light and limp mode

    I checked all the fuses and they are good.

  4. #4
    Top Dog Bionic racing's Avatar
    Join Date
    Aug 2016
    Location
    Idaho/California
    Posts
    1,279

    Re: 2001 gtx maint light and limp mode

    Gtx DI or ? Did you check battery voltage while running @ 3000 rpm ? New to you skis ?
    Last edited by Bionic racing; 07-12-2018 at 01:49 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0