86 js300 electrical nightmare need help
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 4 of 4
  1. #1
    PWCToday Newbie
    Join Date
    Apr 2014
    Location
    Ct
    Age
    30
    Posts
    9

    86 js300 electrical nightmare need help

    Ok so i desperately need some help here. My js300 started this issue where it would be fine then when i would turn it off then go to start it again, nothing. Battery dead. Replaced the battery thinking it was bad. Worked fine for a little then same thing. So far i have replaced starter, starter solenoid, voltage regulator (seemed fine after that) and tested the stator. Also checked ALL wiring and found a few things that were repaired and i thought it was fixed till yesterday. Same thing, turned it off, tried to start it and nothing. Just a few clicks from the ebox. Tried jump starting it with a screw driver but again, nothing. Battery checks out fine at 12.93v. So im at the end of my rope and really need some help here. Anybody have any ideas? Thanks

  2. #2
    PWCToday.com Is My Home Away From Home
    Join Date
    Oct 2013
    Location
    funky town
    Age
    86
    Posts
    6,924

    Re: 86 js300 electrical nightmare need help

    Have you checked the grounds and the integrity of the actual wires? With a good battery and starter, jumping the solenoid should give good brap. Sounds like corroded cables and/or sh!tty ground. (and load test the battery)
    Last edited by whazguude; 07-09-2018 at 01:48 PM.
    I'm only here to make you mad



    I'll tell your girl you said "hi".


  3. #3
    PWCToday Newbie
    Join Date
    Apr 2014
    Location
    Ct
    Age
    30
    Posts
    9

    Re: 86 js300 electrical nightmare need help

    I have gone through ALL wiring and grounds and have found a few things but fixed any issues that i saw that MAY habe been an issue. Not really sure where else to look at this point

  4. #4
    PWCToday.com Is My Home Away From Home
    Join Date
    Aug 2011
    Location
    Austin, Texas, USA
    Age
    52
    Posts
    7,135

    Re: 86 js300 electrical nightmare need help

    The JS300 is notorious for bendix problems. Check this thread: http://www.pwctoday.com/showthread.php?t=282701
    Riding mostly Lake Austin

    1984 JS440 -- 1989 650sx -- 1991 X2 -- 1992 750sx -- 1995 900zxi (qty 2) -- 1995 X2

    Quote Originally Posted by cujo View Post
    God intended PWC to be two strokes, as well as dirt bikes, snowmobiles, and chain saws....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0