2009 SHO FX-not FLUSHING
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 2 of 2
  1. #1
    PWCToday Newbie
    Join Date
    Jun 2018
    Location
    Virginia
    Posts
    7

    2009 SHO FX-not FLUSHING

    Hello,

    New to the form and looking for some help.

    I have a 2009 SHO/FX with 55 hours. This season when I started and turned on the hose to use the flush system. No water went to the engine. Water was coming out the pump housing, but not not the exhaust. The ski was on the trailer and setting level. I went to the ramp and back the ski into the water and started. Water coming out the pee holes on the port side and the vertical hole on the rear deck. I let the ski run for about 7-10 minutes on the trailer. All seemed fine. took the ski out and ran for awhile and all good, no engine over heating. Put it on the ski dock and tried to flush the engine. Same as before, no water out pee holes or the exhaust.

    I talked to the local Yamaha service department, and all I got was, to bring it in for them to check it out for $120.00...

    I'm fairly mechanically capable. as I have have few of the old GP1200, nice rockets. Which I have rebuilt and modified them. My wife want a more refined ski, hence the SHO purchase 2 years ago. Other than normal maintenance, I have not gotten into the ski. It's a bit more complex than the GP1200.

    So any ideas on whats could be happening and or corrections, would be greatly appreciated.

    Spdspinner

  2. #2
    PWCToday Guru butterbean_29512's Avatar
    Join Date
    Sep 2013
    Location
    Bennettsville, SC
    Age
    47
    Posts
    352

    Re: 2009 SHO FX-not FLUSHING

    Maybe you have a dirt dauber in the line? If it flushes in the water, it should flush on the trailer. If it doesn't take the hose apart from the flush connector to the main water line. Check for any blockages. Water not coming from the oil cooler while on the trailer is pretty normal.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0