88 X2 650 wont rev up
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    PWCToday Newbie
    Join Date
    Sep 2017
    Location
    Saskatchewan
    Posts
    41

    Angry 88 X2 650 wont rev up

    Okay I need some help guys. I’m trying to get my 650 X2 running right and cannot make it happen. It’s a rebuilt 650, stock head, good compression, brand new sbn44 and a Factory pipe. It has a 120 low, 150 high and a 2.0 n/s with a black spring. Starting at Low = 1 turn, High = 1.25 turns. The carb is brand new as I thought that was my issue, but I guess not. New BR8ES plugs. It idles good, and revs alright in low RPM’s but it will not rev out. I can only get it into the high RPM’s once or so after starting, but 99% of the time I can’t, it just will not rev up, and starts to sputter with the more throttle I give. It seems to rev up good out of the water. Where do I look now? Pulling my hair out here. Someone on FB suggested my pump bearing could be causing this, but I'm not sure, it seems engine related? Really want to get this things going... Thanks in advance.

    Here's a link to a video: https://www.facebook.com/dustin.c.wi...5276265862234/
    Last edited by dcwilson; 06-18-2018 at 06:06 PM.

  2. #2
    PWCToday.com Is My Home Away From Home bandit88's Avatar
    Join Date
    May 2014
    Location
    Green Bay WI
    Age
    31
    Posts
    2,100

    Re: 88 X2 650 wont rev up

    Sounds like you are too rich, but the video isnt working. Also, what impeller do you have?
    -95 750SXI
    -86 440 with PJS800 conversion (now 650) - http://www.pwctoday.com/showthread.php?t=466927
    -92 750SS
    -81 JS440
    Parts for sale HERE

  3. #3
    Resident Guru JC-SuperJet's Avatar
    Join Date
    Jul 2013
    Location
    Cypress, TX
    Posts
    1,162

    Re: 88 X2 650 wont rev up

    Your current jetting is for a 750 cc engine, thus the jetting is too much, so too rich. Because you have a Kawi 650cc engine, should be closer to a Single Carb 44mm 701 Yamaha Blaster 1 specs.

    Remove the #150 Main Jet and replace it with a #135 Main(High) Jet.
    Last edited by JC-SuperJet; 06-18-2018 at 07:47 PM.

  4. #4
    PWCToday Newbie
    Join Date
    Sep 2017
    Location
    Saskatchewan
    Posts
    41

    Re: 88 X2 650 wont rev up

    Quote Originally Posted by bandit88 View Post
    Sounds like you are too rich, but the video isnt working. Also, what impeller do you have?
    It’s a Skat 15. Anyone else able to see the video? Probably have to be a part of the group I posted it in which is called Kawasaki 650 750 SX SXI X2 Jetmate TS SC

    Quote Originally Posted by JC-SuperJet View Post
    Your current jetting is for a 750 cc engine, thus the jetting is too much, so too rich. Because you have a Kawi 650cc engine, should be closer to a Single Carb 44mm 701 Yamaha Blaster 1 specs.

    Remove the #150 Main Jet and replace it with a #135 Main(High) Jet.
    Really? In all the research I’ve done for my setup most say at least a 140 up to 160 depending on a few things. I have a Factory Pipe on which they say should be jetted up a bit higher as well. I am at 1500ft so I went with a 150 to be safe, as some guys said up to a 160 or so. I have a 140 and a 145 I could try. It only doesn’t rev up when it’s in the water.

  5. #5
    I dream skis
    Join Date
    Mar 2003
    Location
    Shiocton, Wisconsin
    Age
    42
    Posts
    587

    Re: 88 X2 650 wont rev up

    Quote Originally Posted by dcwilson View Post
    It’s a Skat 15. Anyone else able to see the video? Probably have to be a part of the group I posted it in which is called Kawasaki 650 750 SX SXI X2 Jetmate TS SC



    Really? In all the research I’ve done for my setup most say at least a 140 up to 160 depending on a few things. I have a Factory Pipe on which they say should be jetted up a bit higher as well. I am at 1500ft so I went with a 150 to be safe, as some guys said up to a 160 or so. I have a 140 and a 145 I could try. It only doesn’t rev up when it’s in the water.
    I don't think it's the jetting either, I'm running your specs in both my limited SX and X2. They both rip good. I would check all the basic little stuff (exhaust leak, fuel tank breather valve correct direction, clog in water box, fuel tank pick up filter clear, stator / cdi ohm out correctly, flywheel key not sheared, and so on.

    I think I have my X2 carb set 1.25 turns on low and 1 5/8 on high if I remember correctly.
    2001 Superjet; R&D, Blowsion, UMI, Riva, Wetwolf, Ocean Pro.

    1987 650sx: Mariner, UMI, Neo Designes, R&D, Jetsports, Renthal, Hydro-Turf, Skat-Trak, Reworked stock pipe, 40mm carb, Wetwolf F/S cone.

    1986 JS300; lots of mods, fast for a 300...I think

    1987 X2: Rips pretty good and has some 80's flare.

  6. #6
    Frequent Poster
    Join Date
    Nov 2016
    Location
    The Pond
    Posts
    241

    Re: 88 X2 650 wont rev up

    How is your water routing? Where are the headpipe screws set at?

  7. #7
    PWCToday Newbie
    Join Date
    Sep 2017
    Location
    Saskatchewan
    Posts
    41

    Re: 88 X2 650 wont rev up

    Quote Originally Posted by ACP View Post
    I don't think it's the jetting either, I'm running your specs in both my limited SX and X2. They both rip good. I would check all the basic little stuff (exhaust leak, fuel tank breather valve correct direction, clog in water box, fuel tank pick up filter clear, stator / cdi ohm out correctly, flywheel key not sheared, and so on.

    I think I have my X2 carb set 1.25 turns on low and 1 5/8 on high if I remember correctly.
    Thanks ACP. Exhaust is all tight, tank breather is good and the right direction, tank pickup is clear (thought it could be that too). Bypassed the fuel selector to eliminate that. I’ll have to check the water box and the stator/cdi.

    Quote Originally Posted by x2crew View Post
    How is your water routing? Where are the headpipe screws set at?
    Water routing is as Factory pipe recommends. Top and middle screws are closed and bottom is ~3/4.

  8. #8
    PWCToday Newbie
    Join Date
    Sep 2017
    Location
    Saskatchewan
    Posts
    41

    Re: 88 X2 650 wont rev up

    Okay so it seems to be water in the exhaust related. When I run it on a hose, I’m able to get it to rev out initially. But if I let it idle for a bit the exhaust loads up with water and it won’t rev up again. Once I clear the water out of the exhaust, it revs out again as the garden hose water isn’t relevant to the pump pressure. When on the trailer at the lake, the more it revs the more water it pumps into it so it just won’t rev out unless I pull it out of the water. Anyone know what’s going on here? My water lines are routed just as Factory pipe recommends. Something wrong with my waterbox?

  9. #9
    Top Dog aggrovated's Avatar
    Join Date
    Jul 2008
    Location
    Frozen Tundra, MN
    Posts
    1,592

    Re: 88 X2 650 wont rev up

    in your video, I can actually see fuel spitting up out of the carb, Your problem is carb related, too much fuel...and not a good flow. check your reeds, intake (is it the right diameter?)... all of it.. and like jc-superjet said lower your main jet... try the 140.
    Last edited by aggrovated; 06-26-2018 at 12:10 AM.

  10. #10
    PWCToday Newbie
    Join Date
    Sep 2017
    Location
    Saskatchewan
    Posts
    41

    Re: 88 X2 650 wont rev up

    Quote Originally Posted by aggrovated View Post
    in your video, I can actually see fuel spitting up out of the carb, Your problem is carb related, too much fuel...and not a good flow. check your reeds, intake (is it the right diameter?)... all of it.. and like jc-superjet said lower your main jet... try the 140.
    Intake is a BCW racing 44mm intake so it's the proper size. I'll give the smaller jet a go and see what happens, also have another set of reeds to try. Like I said though, water in the exhaust via garden hose, or lake, I'm getting the same results but when the exhaust drys out, it revs up no problem...

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0