Only stays running with choke partially closed
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 6 of 6
  1. #1
    PWCToday.com Is My Home Away From Home SxiPro's Avatar
    Join Date
    May 2005
    Location
    Right here
    Posts
    13,449

    Only stays running with choke partially closed

    Just picked up an FX1 today and even after it warms up it won't stay running(or stumbles and dies) if I don't keep the choke pulled out about 3/8 of an inch. What would cause this? Plus every time I wipe out and it turns on its side a bit, it croaks.

  2. #2
    PWCToday.com Is My Home Away From Home SxiPro's Avatar
    Join Date
    May 2005
    Location
    Right here
    Posts
    13,449

    Re: Only stays running with choke partially closed

    fresh bump

  3. #3
    PWCToday Guru
    Join Date
    Mar 2009
    Location
    Fort myers Fl
    Posts
    328

    Re: Only stays running with choke partially closed

    Itís running lean if the choke helps it. Rebuild your carbs.


    Sent from my iPhone using Tapatalk

  4. #4
    PWCToday.com Is My Home Away From Home SxiPro's Avatar
    Join Date
    May 2005
    Location
    Right here
    Posts
    13,449

    Re: Only stays running with choke partially closed

    Quote Originally Posted by Couchrider View Post
    It’s running lean if the choke helps it. Rebuild your carbs.


    Sent from my iPhone using Tapatalk
    Could it just be a gunked up low speed jet?

  5. #5
    PWCToday.com Is My Home Away From Home Bionic racing's Avatar
    Join Date
    Aug 2016
    Location
    Post falls Idaho
    Posts
    3,275

    Re: Only stays running with choke partially closed

    Check compression , pull carb , check internal filter , plugged with hair balls , rebuild carb , check for cracked fuel lines at selector valve and if has primer kit check supply hose for cracks

  6. #6
    PWCToday.com Is My Home Away From Home SxiPro's Avatar
    Join Date
    May 2005
    Location
    Right here
    Posts
    13,449

    Re: Only stays running with choke partially closed

    Done. Still ain't working

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0