pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 10 of 10
  1. #1
    Frequent Poster
    Join Date
    May 2008
    Location
    Munster,indiana
    Age
    33
    Posts
    179

    95 SPX wont run under load after carb rebuild

    Just recently rebuild the carbs on my 95 spx, genuine mikuni kits with brand new needles and seats. Also replaced all of the fuel lines and even pulled out the fuel selector to clean it before reinstalling everything. The ski will start up and idle fine until the hose is turned on and then it bogs and dies under load unless there is starting fluid being introduced. Not sure if the rotary valve needs to be checked or if water is seeping into the cylinders.

  2. #2
    PWCToday.com Is My Home Away From Home Myself's Avatar
    Join Date
    Jun 2006
    Location
    Arkansas
    Age
    41
    Posts
    5,048

    Re: 95 SPX wont run under load after carb rebuild

    If this is on the trailer then the impeller is not in the water and there is no load. After it dies, pull the spark plugs and look for water droplets.
    http://www.facebook.com/twinlakesjetskirepair

    '89 Kawi 650SX 42.4 GPS
    +3" stock pipe, ported ex. manifold, drilled waterbox, blueprinted pump, Ocean Pro ride plate

    '99 Yama GP1200 65U 61.8 GPS
    ported cylinders, matched cases, milled head, blueprinted pump, long ride plate

    '96 Seadoo HX 717 53.13 GPS
    light porting, massaged cases, lightened flywheel, port matched manifolds, Rossier pipe, stubby pump cone

  3. #3
    Frequent Poster
    Join Date
    May 2008
    Location
    Munster,indiana
    Age
    33
    Posts
    179

    Re: 95 SPX wont run under load after carb rebuild

    Correct it's on the trailer and once the hose is turned fully on it will die during idle. Is it more common to get a hairline crack in the jug or does the base gasket fail more often?

  4. #4
    PWCToday.com Is My Home Away From Home Cliff's Avatar
    Join Date
    Jun 2011
    Location
    Where I can see the air I breathe...
    Posts
    3,892

    Re: 95 SPX wont run under load after carb rebuild

    Were the plugs checked for water droplets?

    A hair line crack would happen if the motor was overheated. I’ve never encountered a torn base gasket. But others may have.
    What would Chuck Norris do?

  5. #5
    Frequent Poster
    Join Date
    May 2008
    Location
    Munster,indiana
    Age
    33
    Posts
    179

    Re: 95 SPX wont run under load after carb rebuild

    The plugs were a tad bit wet but with oil.

  6. #6
    Resident Guru JC-SuperJet's Avatar
    Join Date
    Jul 2013
    Location
    Cypress, TX
    Posts
    963

    Re: 95 SPX wont run under load after carb rebuild

    I've heard that the plastic Seadoo Fuel Tank Pick-Up Tubes tend to crack and leak...maybe take a look and see.

  7. #7
    PWCToday.com Is My Home Away From Home Cliff's Avatar
    Join Date
    Jun 2011
    Location
    Where I can see the air I breathe...
    Posts
    3,892

    Re: 95 SPX wont run under load after carb rebuild

    Quote Originally Posted by edobi21 View Post
    The plugs were a tad bit wet but with oil.
    Sounds like a rich condition. You’ll need to set the idle speed to spec at 3,000 rpm on the trailer and 1,500 rpms with the pump loaded in the water. You’ll need to adjust the low speed screws in at 1/8 turns until you can achieve a crisp & clean pull of the throttle while adjusting the idle speed to 1,500 rpms each time you make an adjustment to the screws. Change those plugs to new BR8ES plugs gapped at 0.20” - 0.24” and adjust from there. It’s best to have the pump in the water when adjusting the carbs.

    Is this ski stock or modded in any way?
    Last edited by Cliff; 06-04-2018 at 05:27 PM.
    What would Chuck Norris do?

  8. #8
    Frequent Poster
    Join Date
    May 2008
    Location
    Munster,indiana
    Age
    33
    Posts
    179

    Re: 95 SPX wont run under load after carb rebuild

    No the ski is 100% stock and the low speed was set to 1-1/8 per the manual and plugs gapped at .24"

  9. #9
    Resident Guru hafweigthr's Avatar
    Join Date
    May 2009
    Location
    South Carolina
    Age
    54
    Posts
    974

    Re: 95 SPX wont run under load after carb rebuild

    You checked carb pop off and verified that you have fuel flow through both carbs (return orifice in carbs is clear). Sounds like a fuel issue.

    I'm going to sound like a broken record but when you do carb and fuel line work you need to prime and pressure test the fuel system. That way you know that most everything is working like it should, you have fuel flow, and you have no leaks. Leaking fuel into a jet ski hull is not a good thing even with flame arrestors.
    The thought that leads to no action is not thought - It is dreaming!!
    Think Big!!

    Some people have hobbies - some people have addictions - I have jet skis!!

  10. #10
    Frequent Poster
    Join Date
    May 2008
    Location
    Munster,indiana
    Age
    33
    Posts
    179

    Re: 95 SPX wont run under load after carb rebuild

    The ski is at the lake house, but im going to pull the return line of the carbs and make sure they're both getting enough fuel next weekend when i'm up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0