06 GTX LTD oil issues
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 9 of 9
  1. #1
    PWCToday Newbie
    Join Date
    Sep 2013
    Location
    buffalo, ny
    Age
    22
    Posts
    17

    06 GTX LTD oil issues

    I picked up an 06 GTX LTD 215 witg 210 hours pretty cheap over the winter. The previous owner told me it has a bad oil pump.

    I immediately questioned this because the dealership did not tear into the ski, only an assumption. His description of what happened was; "I hit a decent sized wake going decently fast and when I came down the oil light came on. I shut it off immediately and drifted to the marina. I started it up to get on the dock and it seemed fine but still had the light."

    They also sold him a brand new seadoo, another reason I'm skeptical. I looked into 4tec's having issues with oil pumps and they don't seem to go bad unless the supercharger goes (which was done about 50 hours prior). My next thought was an oil pressure sensor going bad, which does seem common. The oil looks brand new and is up to the top on the dipstick.

    Does anyone have experience with an issue like this? I'm afraid to start it if one of the oil pumps is bad.

  2. #2
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    51
    Posts
    8,256

    Re: 06 GTX LTD oil issues

    Yes, oil switches are common on the Seadoo's. There are two, one down on the Lower RH rear side of the block and one up front.


    I test with an oil pressure gauge. If you have pressure within spec, your oil pump is ok, and it is typically a bad switch.
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web sites

    new parts / products / services www.watcon.com
    used parts www.rockcountyjetski.webs.com
    thank you

    Please check out and like WATCON on Facebook

  3. #3
    PWCToday.com Is My Home Away From Home Myself's Avatar
    Join Date
    Jun 2006
    Location
    Arkansas
    Age
    41
    Posts
    5,143

    Re: 06 GTX LTD oil issues

    There is a 1/8" pipe thread fitting ar the rear of the head right side. Tap in there with a pressure gauge and see what he pressure actually is.
    http://www.facebook.com/twinlakesjetskirepair

    '89 Kawi 650SX 42.4 GPS
    +3" stock pipe, ported ex. manifold, drilled waterbox, blueprinted pump, Ocean Pro ride plate

    '99 Yama GP1200 65U 61.8 GPS
    ported cylinders, matched cases, milled head, blueprinted pump, long ride plate

    '96 Seadoo HX 717 53.13 GPS
    light porting, massaged cases, lightened flywheel, port matched manifolds, Rossier pipe, stubby pump cone

  4. #4
    PWCToday Newbie
    Join Date
    Sep 2013
    Location
    buffalo, ny
    Age
    22
    Posts
    17

    Re: 06 GTX LTD oil issues

    Thanks guys. I'll put a gauge on it and check back.
    89' JS300
    89' 650sx
    97' SeaDoo GS
    06' SeaDoo GTX 215

  5. #5
    PWCToday Newbie
    Join Date
    Sep 2013
    Location
    buffalo, ny
    Age
    22
    Posts
    17

    Re: 06 GTX LTD oil issues

    https://youtu.be/ZjEehEo_KoM

    I put a gauge on it today (a cheap harbor freight one) and it seems to be making lots of oil pressure. I need to check the manual for what it's supposed to be.

    The idle was hunting slightly and oil pressure was fluctuating between 30&40. No warnings in the few seconds I had it running.

    Any thoughts?
    89' JS300
    89' 650sx
    97' SeaDoo GS
    06' SeaDoo GTX 215

  6. #6
    PWCToday.com Is My Home Away From Home Myself's Avatar
    Join Date
    Jun 2006
    Location
    Arkansas
    Age
    41
    Posts
    5,143

    Re: 06 GTX LTD oil issues

    That looks perfectly normal to me. Climbed up pretty quick after you started it. Check and make sure you don't have a collapsed oil filter but I'm thinking simply bad sensor right rear of block.
    http://www.facebook.com/twinlakesjetskirepair

    '89 Kawi 650SX 42.4 GPS
    +3" stock pipe, ported ex. manifold, drilled waterbox, blueprinted pump, Ocean Pro ride plate

    '99 Yama GP1200 65U 61.8 GPS
    ported cylinders, matched cases, milled head, blueprinted pump, long ride plate

    '96 Seadoo HX 717 53.13 GPS
    light porting, massaged cases, lightened flywheel, port matched manifolds, Rossier pipe, stubby pump cone

  7. #7
    PWCToday Newbie
    Join Date
    Sep 2013
    Location
    buffalo, ny
    Age
    22
    Posts
    17

    Re: 06 GTX LTD oil issues

    The oil pressure jumped up pretty high (looked to be around 80psi) on first start up (I cranked it for a few seconds to prime) but according to the manual that is normal.

    Am I correct in thinking that the main pump is what circulates oil and the suction pump acts like a "dry sump" pump?

    Looks like I dodged a bullet on this one.
    89' JS300
    89' 650sx
    97' SeaDoo GS
    06' SeaDoo GTX 215

  8. #8
    PWCToday.com Is My Home Away From Home Myself's Avatar
    Join Date
    Jun 2006
    Location
    Arkansas
    Age
    41
    Posts
    5,143

    Re: 06 GTX LTD oil issues

    Correct, a scavenging pump and a main pump.
    http://www.facebook.com/twinlakesjetskirepair

    '89 Kawi 650SX 42.4 GPS
    +3" stock pipe, ported ex. manifold, drilled waterbox, blueprinted pump, Ocean Pro ride plate

    '99 Yama GP1200 65U 61.8 GPS
    ported cylinders, matched cases, milled head, blueprinted pump, long ride plate

    '96 Seadoo HX 717 53.13 GPS
    light porting, massaged cases, lightened flywheel, port matched manifolds, Rossier pipe, stubby pump cone

  9. #9
    PWCToday Newbie
    Join Date
    Sep 2013
    Location
    buffalo, ny
    Age
    22
    Posts
    17

    Re: 06 GTX LTD oil issues

    So I attempted to put the ski in the water today and discovered there is an actual issue. Rode it for about a minute and came back to shore to find this.
    IMG_20180528_112629178.jpg
    It seems like oil is leaking out of the front and possibly the bottom (or oil is running down the front and dripping)

    Any ideas? The 1/8npt plug seemed tight and nothing looks visibly loose.
    89' JS300
    89' 650sx
    97' SeaDoo GS
    06' SeaDoo GTX 215

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0