86’ JS550 ground wire?
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 5 of 5
  1. #1
    PWCToday Newbie zxkyler's Avatar
    Join Date
    Nov 2017
    Location
    Southern Maine
    Posts
    35

    86’ JS550 ground wire?

    Hey guys, I just picked up an 86’ JS550 and was cleaning up some of the wiring and noticed that the ground from the ebox was broken off at one end. I put a new connector on the end and now I’m not sure where im supposed to ground it too but heres a pic

    Thanks in advance.
    Attached Images Attached Images

  2. #2
    PWCToday Regular PiranahIndustries's Avatar
    Join Date
    Nov 2016
    Location
    Chicago, IL
    Posts
    65

    Re: 86’ JS550 ground wire?

    Should ground to battery negative terminal or to the motor block on one of the intake studs.
    Is the red wire w/ 1/2 of a crimped connector for a bilge? Bilge negative will also need to be tied to a ground.
    1987 JS550/750 Conversion “Big Red”

  3. #3
    PWCToday.com Is My Home Away From Home BLRider's Avatar
    Join Date
    Apr 2007
    Location
    SE MI
    Age
    54
    Posts
    8,609

    Re: 86’ JS550 ground wire?

    That small wire goes from the ebox to the engine without it your engine won't run.
    Never argue with an idiot, they will drag you down to their level then beat you with experience.

  4. #4
    PWCToday Newbie zxkyler's Avatar
    Join Date
    Nov 2017
    Location
    Southern Maine
    Posts
    35

    Re: 86’ JS550 ground wire?

    Thanks for the quick reply! Yes that other wire is for the bilge pump and yes I did ground it to the battery thanks Piranah. Ill check to see if there's a broken connector on one of my intake studs tomorrow and if not I'll ground it to one or the battery terminal.

  5. #5
    PWCToday Newbie zxkyler's Avatar
    Join Date
    Nov 2017
    Location
    Southern Maine
    Posts
    35

    Re: 86’ JS550 ground wire?

    BLRider thanks for the reply, I did have the motor running today without it connected but I'm sure Its not good having that ebox not grounded correctly!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0