HELP. 1994 WRIII GP bogging issue ??!!
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    PWCToday Regular
    Join Date
    Feb 2017
    Location
    Mechanicsburg, PA
    Age
    38
    Posts
    97
    Blog Entries
    1

    HELP. 1994 WRIII GP bogging issue ??!!

    Hey need some help. My 94 GP has a fresh 701 rebuild and carb rebuild. It fires up great on the water and goes like hell for 10-15 min. Seems like after 15 minutes or so if Iím stopped or idling when I go to take off again it bogs down and cuts out. IT will fire right up again but every time I give it gas it cuts out. Anyone ever have this issue before? The inline fuel filter was changed before I fired up the rebuilt motor. I deleted the oil injection during rebuild as well. Any help would be great! Thanks!!

  2. #2
    PWCToday.com Is My Home Away From Home Myself's Avatar
    Join Date
    Jun 2006
    Location
    Arkansas
    Age
    41
    Posts
    5,134

    Re: HELP. 1994 WRIII GP bogging issue ??!!

    After it bogs, immediately go to shallow water, hop off and pop the hood. Look for any sign of exhaust fumes. The fiberglass waterbox on those commonly blows open.
    http://www.facebook.com/twinlakesjetskirepair

    '89 Kawi 650SX 42.4 GPS
    +3" stock pipe, ported ex. manifold, drilled waterbox, blueprinted pump, Ocean Pro ride plate

    '99 Yama GP1200 65U 61.8 GPS
    ported cylinders, matched cases, milled head, blueprinted pump, long ride plate

    '96 Seadoo HX 717 53.13 GPS
    light porting, massaged cases, lightened flywheel, port matched manifolds, Rossier pipe, stubby pump cone

  3. #3
    PWCToday Regular
    Join Date
    Feb 2017
    Location
    Mechanicsburg, PA
    Age
    38
    Posts
    97
    Blog Entries
    1

    Re: HELP. 1994 WRIII GP bogging issue ??!!

    I forgot to mention it has an aftermarket TDR water box on it....

  4. #4
    PWCToday Regular
    Join Date
    Feb 2017
    Location
    Mechanicsburg, PA
    Age
    38
    Posts
    97
    Blog Entries
    1

    Re: HELP. 1994 WRIII GP bogging issue ??!!

    Your thinking it is an air leak?

  5. #5
    PWCToday.com Is My Home Away From Home WFO Speedracer's Avatar
    Join Date
    Aug 2006
    Location
    Al-ugh-bam-ugh
    Posts
    26,147

    Re: HELP. 1994 WRIII GP bogging issue ??!!

    I did have one of these a few years back that gave me a run for my money, the culprit turned out to be a bad waterbox, my suggestion is simple find a piece of pvc pipe that will span the area the waterbox is in, remove the waterbox install the pipe and go run it, yes it will be loud but you will know within a few minutes if that is your issue or not.

    The waterbox on this particular unit did not have an exhaust leak , there was evedince that it had been run hot and melted the inside of the box obstructing the exhaust flow and making the ski run richer and richer till it would no longer plane out.
    Last edited by WFO Speedracer; 02-18-2018 at 04:31 PM.
    Y'all know me, still the same O.G. but I been low-key
    hated on by most these &^$$@s with no cheese, no deals and no G's, no wheels and no keys, no boats, no snowmobiles, and no skis, mad at me cause I can finally afford to provide my family with groceries


  6. #6
    PWCToday Regular
    Join Date
    Feb 2017
    Location
    Mechanicsburg, PA
    Age
    38
    Posts
    97
    Blog Entries
    1

    Re: HELP. 1994 WRIII GP bogging issue ??!!

    Interesting! Thanks for the advice. I will try it out.

  7. #7
    PWCToday Regular
    Join Date
    Feb 2017
    Location
    Mechanicsburg, PA
    Age
    38
    Posts
    97
    Blog Entries
    1

    Re: HELP. 1994 WRIII GP bogging issue ??!!

    Is it possible the overheat sensor if messed up? Fuel pickups?

  8. #8
    PWCToday.com Is My Home Away From Home
    Join Date
    May 2007
    Location
    Arkansas
    Posts
    2,198

    Re: HELP. 1994 WRIII GP bogging issue ??!!

    See if you can blow through the fuel tank check valve and make sure the vent line isn't bent shut.

  9. #9
    PWCToday Regular
    Join Date
    Feb 2017
    Location
    Mechanicsburg, PA
    Age
    38
    Posts
    97
    Blog Entries
    1

    Re: HELP. 1994 WRIII GP bogging issue ??!!

    I will thank you

  10. #10
    PWCToday.com Is My Home Away From Home WFO Speedracer's Avatar
    Join Date
    Aug 2006
    Location
    Al-ugh-bam-ugh
    Posts
    26,147

    Re: HELP. 1994 WRIII GP bogging issue ??!!

    Just open the electrical box and unplug the heat sensor to determine if that is an issue or not. I have run across several of those TDR boxes where the baffles have come loose, if you shake the waterbox and it rattles it is bad.
    Last edited by WFO Speedracer; 02-19-2018 at 07:43 AM.
    Y'all know me, still the same O.G. but I been low-key
    hated on by most these &^$$@s with no cheese, no deals and no G's, no wheels and no keys, no boats, no snowmobiles, and no skis, mad at me cause I can finally afford to provide my family with groceries


Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0