pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 5 of 5
  1. #1
    PWCToday Newbie
    Join Date
    Dec 2017
    Location
    Boynton Beach
    Age
    43
    Posts
    5

    Polaris SLH stalls under load

    I have an 01 SLH, that idles and runs out of the water. However, when I put it in the water it runs fine until about 3000 rpms, but you go past it dies, I can get it up to full throttle by messing with the choke while feathering on the throttle. I have rebuilt the carbs and adjusted the jets, but the result is the same no matter how I turn them in or out, so I have them adjusted back to 1 7/8. Any advice would be greatly appreciated.

  2. #2
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    50
    Posts
    9,836

    Re: Polaris SLH stalls under load

    If it is running poor, and you can get it better by playing with the choke, it sounds as you have a fuel related issue.

    When you rebuilt the carb(s) what kits did you use? Where they genuine Kehin brand, or genuine Polaris. Or aftermarket, like Winderosa, WSM, etc? I ask as I personally have never had any luck with ANY aftermarket kits. Also, you may still have some internal blockage. Especially if this is a salt water ski, I have seen carbs get really custy, to the point they really cannot even be rebuilt.

    Do not over look other issues / areas. A lean condition can come from an air leak, blockage somewhere else in the fuel system (ie fuel select vavle) bad fuel pick ups, fuel lines, bad reeds, and so on.
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web sites

    new parts / products / services www.watcon.com
    used parts www.rockcountyjetski.webs.com
    thank you

    Please check out and like WATCON on Facebook

  3. #3
    PWCToday Newbie
    Join Date
    Dec 2017
    Location
    Boynton Beach
    Age
    43
    Posts
    5

    Re: Polaris SLH stalls under load

    John, Thanks for the reply. I did use an aftermarket rebuild. I will order a new one. Also there is no air movement in the vent line. Could this be the problem as well? Could a blocked check valve or vent cause the same issue?

  4. #4
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    50
    Posts
    9,836

    Re: Polaris SLH stalls under load

    Yes, vent line / check valve is also important, and needs to be working properly.

    Take the valve off, and try to suck/blow through it. It should go one way. (Let air into tank, not out).

    I have Genuine Kehin kits, and new check valves in stock. www.watcon.com

    Another thought, when you rebuilt the carbs, did you replace the needle arm spring? Did you make sure to match it to the original spring. Sometimes kits come with the wrong spring. Do you still have the original / old parts, and spring?
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web sites

    new parts / products / services www.watcon.com
    used parts www.rockcountyjetski.webs.com
    thank you

    Please check out and like WATCON on Facebook

  5. #5
    PWCToday Newbie
    Join Date
    Dec 2017
    Location
    Boynton Beach
    Age
    43
    Posts
    5

    Re: Polaris SLH stalls under load

    Thanks again. The check valve is definitely bad. I will get on the site and place an order!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0