pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 8 of 8
  1. #1
    PWCToday Newbie
    Join Date
    Oct 2017
    Location
    FL
    Posts
    8

    WR650 high speed miss

    91 650 runs great Idles good go to high speed and keeps missing and cutting out after you run for a bit it will clear up and scream New carb new plugs gapped at 28 running premix at 40:-1

  2. #2
    PWCToday Guru alaski's Avatar
    Join Date
    Apr 2015
    Location
    Alaska
    Age
    66
    Posts
    326

    Re: WR650 high speed miss

    Quote Originally Posted by jeffinfl View Post
    91 650 runs great Idles good go to high speed and keeps missing and cutting out after you run for a bit it will clear up and scream New carb new plugs gapped at 28 running premix at 40:-1
    Have a water seperater type fuel filter in there?

  3. #3
    PWCToday Newbie
    Join Date
    Oct 2017
    Location
    FL
    Posts
    8

    Re: WR650 high speed miss

    No just inline filter

  4. #4
    PWCToday Guru alaski's Avatar
    Join Date
    Apr 2015
    Location
    Alaska
    Age
    66
    Posts
    326

    Re: WR650 high speed miss

    Great! Might be an easy fix (except mounting sometimes). Should be using it anyway though!

  5. #5
    PWCToday.com Is My Home Away From Home freekstyle's Avatar
    Join Date
    Aug 2007
    Location
    801
    Posts
    3,214

    Re: WR650 high speed miss

    Coil wires/high tension leads are boken inside insulation. Check the plug caps also.

  6. #6
    PWCToday.com Is My Home Away From Home Chester's Avatar
    Join Date
    Feb 2002
    Location
    Vancouver, BC Canada
    Age
    56
    Posts
    3,148

    Re: WR650 high speed miss

    It's hitting the rev limiter. Check the impeller for debris or damage.

    Chester
    Speed is very expensive. How fast do you want to spend?

    Stand up:
    98 SXi-Pro

    Couches:

    96 XP
    86 X2

  7. #7
    PWCToday.com Is My Home Away From Home Chester's Avatar
    Join Date
    Feb 2002
    Location
    Vancouver, BC Canada
    Age
    56
    Posts
    3,148

    Re: WR650 high speed miss

    Quote Originally Posted by Chester View Post
    It's hitting the rev limiter. Check the impeller for debris or damage.

    Chester
    It's from cavitation.

    Chester
    Speed is very expensive. How fast do you want to spend?

    Stand up:
    98 SXi-Pro

    Couches:

    96 XP
    86 X2

  8. #8
    PWCToday.com Is My Home Away From Home WFO Speedracer's Avatar
    Join Date
    Aug 2006
    Location
    Al-ugh-bam-ugh
    Posts
    27,361

    Re: WR650 high speed miss

    Chester is probably right on this one, those have aluminum impellers and they get chewed all to hell by this age on that ski, there is also a good possibility that either the coil wires or the plug caps have gone bad as well, I have repaired many running issues on those by installing NGK style spark plug caps in place of the crap stock ones.
    Y'all know me, still the same O.G. but I been low-key
    hated on by most these &^$$@s with no cheese, no deals and no G's, no wheels and no keys, no boats, no snowmobiles, and no skis, mad at me cause I can finally afford to provide my family with groceries


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0