pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 5 of 5
  1. #1
    PWCToday Newbie
    Join Date
    Oct 2017
    Location
    FL
    Posts
    6

    91 Waverunner 650 wont run

    Compression good, was not getting any spark so I replaced CDI and Coil started up and shut it off very quick. backed it into the water and started it it ran for 10 seconds and died, put inline spark tester in and it's getting good spark. looked in carb while cranking and gas is dripping in so I pulled the plugs and replaced them and tried again still wont start so I unplugged the stop switch and still no good any ideas ????

  2. #2
    PWCToday Guru alaski's Avatar
    Join Date
    Apr 2015
    Location
    Alaska
    Age
    66
    Posts
    321

    Re: 91 Waverunner 650 wont run

    Think you'll need a new Mikuni needle and seat but doubtless the carb should be completely rebuilt. This is not as daunting as it sounds. Suggest you PM member RDRTTOY. He'll fix you right up mate.

  3. #3
    PWCToday Newbie
    Join Date
    Oct 2017
    Location
    FL
    Posts
    6

    Re: 91 Waverunner 650 wont run

    I had a kit and rebuilt the carb but It didn't come with a needle and seat. I did notice that even after you stop cranking gas continues to flow into the carb I suppose until the pressure drops. Could it be flooding ??

  4. #4
    I dream skis Squarenosed's Avatar
    Join Date
    Nov 2007
    Location
    Bonita, CA (so cal)
    Age
    32
    Posts
    654

    Re: 91 Waverunner 650 wont run

    If you have good compression and spark is consistent then yes it sounds like it's flooding, especially if you have constant fuel flow with nothing else going on. Do the plugs looked soaked with fuel when you remove them?
    My small fleet...[90 SN SJ ] [90 X2] [90 Jet-n-Cat ]

  5. #5
    PWCToday Newbie
    Join Date
    Oct 2017
    Location
    FL
    Posts
    6

    Re: 91 Waverunner 650 wont run

    Ok got my new needle and seat today after putting in new kit and needle and seat I started and adjusted high and low and it ran great and idled fine ran around the lake several times and parked it and back to the same thing. Fuel leaking into the carb after shut off, I managed to get it running but you have to keep throttle or it will load up and die. I am guessing I have a piece of dirt somewhere maybe holding needle valve open Thoughts. ??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0