pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 2 of 2
  1. #1
    PWCToday Newbie Jlstreccius's Avatar
    Join Date
    Aug 2015
    Location
    North Dakota
    Posts
    4

    98 Seadoo GTX RFI mag injector not working

    I have a 98 GTX RFI project that I am puzzled with. I bought this ski as a project and rebuilt the motor, new pistons rings, crank seals, etc. the only history I have on the machine from the original owner is that it was a lemon. After reassembly. It starts poorly and only idles on the PTO cylinder. There is good spark on the MAG side. All sensors test good. I pulled the injector rail and fuel only sprays on the PTO injector. At half throttle or full throttle the result is the same. I switched wiring on the injectors and the Mag injector sprays the same as the PTO at all positions of the throttle but still only one injector sprays. When the ski is running the Maintenance light is flashing. I have attempted to rest but it continues. I took the ski to a certified mechanic/friend who does side work at home and has the electronics to test the system. He thinks it may be the MPEM but is not convinced this will fix it.

    One additional concern from the rebuild I have is that I removed the magnet ring on the flywheel, thinking this was necessary for flywheel removal. If the ring was installed incorrectly could this cause the injector problem? I was confident when reassembling that I got it right but now I am not sure? Please help.

    Additional question: Can the MPEM be sent out for testing?

  2. #2
    PWCToday Newbie Jlstreccius's Avatar
    Join Date
    Aug 2015
    Location
    North Dakota
    Posts
    4

    Re: 98 Seadoo GTX RFI mag injector not working

    So here are the active codes on the ski.
    P0118 Engine temp sensor under lower limit.
    P0335 Engine speed signal not detected.
    P0108 Intake Pressure sensor above upper limit
    P1200 Mag fuel Injector open

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0