pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 5 of 5
  1. #1
    PWCToday Newbie aquanut's Avatar
    Join Date
    Sep 2013
    Location
    Delaware Coast
    Age
    49
    Posts
    40

    Not the wear ring after all.

    I recently bought two jet skis in the last month to add to my 92 Seadoo XP , A 92 TS 650 for $550 and a 84 JS 550 for $500 which i haven't tried yet , Anyway i figured the ts had a wear ring going bad because it slipped on takeoff and you had to really baby it to get it going but once it did it ran great , A few days ago i went out and soon as i got it going it really slipped even on top end so i thought the wear ring was completely shot at this point so i putted back to the dock, Took the plugs out and they were soaked and its been putting out way more smoke than i thought it should have all this time. So the new plugs got it running again but the low end still sucks like its slipping , Seeing how it was the same slipping feeling on top end when the plugs fouled i started thinking maybe the carb is outta wack so i checked it and they were way off , The low speed was 2-1/2 turns out and the high speed was 1-1/2 so i set them to factory settings i found on here and Man what a difference , its like a totally different ski now , very little smoke at all , it did still have a slight slipping feeling which i know now its bogging but just after idle it comes to life so I'm thinking of turning the low speed just a hair at a time until i get no hesitation at all of a idle. I set them at 1-1/8 for low and 3/4 for high , I do want to buy a pop off gauge and learn how to use it. I'm going to pick up a set of new plugs and filter tomorrow seeing how i rode the other day for over a hour with it like it was and i probably put a hurting on the plugs seeing how the last pair didn't last long at all and when i checked to see if the filter was dirty there was no filter in it at all. Any tips on carb tuning is appreciated as I'm new to tuning these things.

  2. #2
    Top Dog Benflynn's Avatar
    Join Date
    Aug 2015
    Location
    Birmingham
    Posts
    1,535

    Re: Not the wear ring after all.

    What is slipping feeling? More revs than power? If it over revs and dosnt accel it's cavitating or airiating, prob the latter

  3. #3
    Top Dog Benflynn's Avatar
    Join Date
    Aug 2015
    Location
    Birmingham
    Posts
    1,535

    Re: Not the wear ring after all.

    Look up the minuki tuning guide, or search, there is a step by step process, it works well of everything is in good shape, and when everything is stock and good shape stock settings should get u close

  4. #4
    PWCToday Newbie aquanut's Avatar
    Join Date
    Sep 2013
    Location
    Delaware Coast
    Age
    49
    Posts
    40

    Re: Not the wear ring after all.

    Well slipping was probably the wrong term , When my xp 580 wear ring was shot it sorta felt like that , You had to give it throttle little by little to get it going then once it was going you could nail it but not from the start and riding my 11 year old on it was terrible to the point you weren't sure if you could get it going , Now i know it was a carb problem because its totally comes to life now , It only has that feeling from idle to maybe 1/4 throttle now if that , Before it was probably half or more throttle to get it going , It had no low end at all and the only thing i had to compare it to was the seadoo when the wear ring went south sorta the same feeling when you suck up a plastic bag.

  5. #5
    PWCToday Newbie aquanut's Avatar
    Join Date
    Sep 2013
    Location
    Delaware Coast
    Age
    49
    Posts
    40

    Re: Not the wear ring after all.

    Compression was 123 in each cylinder , at first it showed 119 but i used a better gauge the next time i use for the drag cars , I've always been great with carbs on race cars but never messed with them on jet skis. I'm surprised it ran at all the way it was adjusted , I kept telling my wife i cant believe it hasn't fouled the plugs yet as bad as it was smoking. I did read some tuning stuff on them that said start with the factory settings and test it out and if you have a slight hesitation from idle then turn a 1/8 at a time until its gone then test the top end and do the same.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0