pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    PWCToday Regular
    Join Date
    Jul 2011
    Location
    Dearborn, Michigan
    Age
    47
    Posts
    55

    02 GTX-DI stator voltage low/non existant

    Hey all. I was wondering if I could get a bit of advice. I get about 12.5 volts while engine is running at higher rpm.

    I thought it was the aftermarket fuel pump drawing too much current. After further inspection it turns out my stator only generates AC voltage on 2 out of the 3 possible combinations.

    Also, that phase reads 1.5 ohms of resistance to the phase that I don't get a voltage reading on.

    I use a megger to check for a short to ground and all 3 phases are OK.

    In your opinion does it seem that the stator needs to be replaced?

  2. #2
    I dream skis Bionic racing's Avatar
    Join Date
    Aug 2016
    Location
    Idaho/California
    Posts
    744

    Re: 02 GTX-DI stator voltage low/non existant

    Had similar problem on a DI , ended up being bad MPEM , tried known good stator , and two known good rectifiers ,

  3. #3
    PWCToday Regular
    Join Date
    Jul 2011
    Location
    Dearborn, Michigan
    Age
    47
    Posts
    55

    Re: 02 GTX-DI stator voltage low/non existant

    I have the stator unplugged from the rest of the system where it should just be generating a voltage between all 3 phases. Shouldn't I get ac voltage from the stator between all 3 phases? How would a bad mpem cause that issue?
    Last edited by eavedesian; 09-23-2017 at 05:27 PM.

  4. #4
    I dream skis Bionic racing's Avatar
    Join Date
    Aug 2016
    Location
    Idaho/California
    Posts
    744

    Re: 02 GTX-DI stator voltage low/non existant

    Beat our heads against the wall on similar problem , MPEM was culprit , this was MPEM year all the way to a four wire 657 which had a bad voltage reg in MPEM that was giving symptoms of bad rectifier , over charging , but ended up being MPEM in the end not rectifier

  5. #5
    PWCToday Regular
    Join Date
    Jul 2011
    Location
    Dearborn, Michigan
    Age
    47
    Posts
    55

    Re: 02 GTX-DI stator voltage low/non existant

    Don't hate me but one final time, if the stator unplugged from the rest of the system doesn't even go to the mpem, it is just the rotation of the motor generating the AC field/voltage. It hasn't even gotten to the rectifier yet much less the mpem. You ran into this same thing with the AC voltage missing on one phase?

  6. #6
    I dream skis Bionic racing's Avatar
    Join Date
    Aug 2016
    Location
    Idaho/California
    Posts
    744

    Re: 02 GTX-DI stator voltage low/non existant

    Your mag is putting out correct voltage ? If not then change your stator

  7. #7
    PWCToday Regular
    Join Date
    Jul 2011
    Location
    Dearborn, Michigan
    Age
    47
    Posts
    55

    Re: 02 GTX-DI stator voltage low/non existant

    When checking voltage on 2 out of the 3 possible combinations (A to B, B to C, and C to A) it is giving me correct voltage. However one of the combinations is dead.

  8. #8
    I dream skis Bionic racing's Avatar
    Join Date
    Aug 2016
    Location
    Idaho/California
    Posts
    744

    Re: 02 GTX-DI stator voltage low/non existant

    Pull stator cover and do visual , does it look burnt or smell like it got hot ? The bendixs tear up all the time and throw shrapnel onto stator and short it out , check bendix to make sure counter weight limiters are all there , and weight return spring still is around them to complete diagnosis , have you used an ohm meter to check stator resistance yet ? Was this a ski you just purchased with pre existing problem or did it just tear up ? If new to you a DI was not the best choice for a cheap fixer upper , those skis when they come in for repairs are 500$ just to roll over the curb into the shop , most shop won't even touch them , like a Polaris watercraft

  9. #9
    PWCToday Regular
    Join Date
    Jul 2011
    Location
    Dearborn, Michigan
    Age
    47
    Posts
    55

    Re: 02 GTX-DI stator voltage low/non existant

    I bought it "fully working" with a fresh SES engine so previous guy had it torn apart. I've had this lower voltage issue since i got it.

    I've measured resistance and that one dead phase is over 1 ohm, about 1.5 ohms and other 2 phases read below 1 ohm like they should read.

    Oh, and thank you for all your help and patience. Had an 01 RXDI and LOVED IT! Plus my 1100 Venture just sucked wayyyyy to much gas for my taste! Lol!so I bought this and an 03 RXDI. LOL.
    Last edited by eavedesian; 09-24-2017 at 04:03 PM.

  10. #10
    Resident Guru
    Join Date
    Aug 2008
    Location
    Indianapolis
    Posts
    1,072

    Re: 02 GTX-DI stator voltage low/non existant

    Then your stator is no good.....

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0