2001 Seadoo GTX 951 DI starting issue
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    I dream skis charliebabb's Avatar
    Join Date
    Dec 2010
    Location
    Brawley
    Posts
    745

    2001 Seadoo GTX 951 DI starting issue

    Hey all, I am having a strange issue with TWO of my identical 2001 951 GTX DI skis. I first noticed the issue about a week ago. I went out to start my blue gtx and all it did was click and i would get an endless amount of single beeps, which is strange because i have never read about that beep pattern anywhere. So i initially assume maybe a bad battery. Swapped it out and the ski started and ran great. After assuming the issue is resolved, I disconnect the positive post and leave the ski for another week. I come out today to fire both blue and red skis up before taking them to the lake and they BOTH are doing the exact same thing! I connect the DESS key and i get two regular beeps and the fuel pump kicks on and everything. I push the start button and i get the click from the starter solenoid and some weird beep patterns. Usually just the multiple beeps like i mentioned above but sometimes it will initially produce a quick "muted" beep and a fast one after and then endless single beeps. Any thoughts?

  2. #2
    PWCToday.com Is My Home Away From Home bills86e's Avatar
    Join Date
    May 2008
    Location
    florida
    Posts
    3,238

    Re: 2001 Seadoo GTX 951 DI starting issue

    You need 12.5 volts charge min.

  3. #3
    I dream skis charliebabb's Avatar
    Join Date
    Dec 2010
    Location
    Brawley
    Posts
    745

    Re: 2001 Seadoo GTX 951 DI starting issue

    The battery is charged and good. I even tried a brand new battery today. Same thing

  4. #4
    I dream skis charliebabb's Avatar
    Join Date
    Dec 2010
    Location
    Brawley
    Posts
    745

    Re: 2001 Seadoo GTX 951 DI starting issue

    I checked the negative cable going to starter and positives from battery to elec box to starter. All seemed good. I cleaned the cable terminals on batteries too. Still the same issue. Any thoughts?

  5. #5
    Resident Guru
    Join Date
    Jun 2006
    Location
    PA
    Age
    58
    Posts
    812

    Re: 2001 Seadoo GTX 951 DI starting issue

    You have a voltage droop issue going on, which is likely causing the funky beep pattern your getting; the MPEM is floating into a state of non-operation. I'll assume your check of the cables was visual. Do you have a voltmeter?

  6. #6
    I dream skis charliebabb's Avatar
    Join Date
    Dec 2010
    Location
    Brawley
    Posts
    745

    Re: 2001 Seadoo GTX 951 DI starting issue

    Yes i have a meter. What kind of tests are you thinking?
    Last edited by charliebabb; 08-28-2017 at 01:44 AM.

  7. #7
    Resident Guru
    Join Date
    Jun 2006
    Location
    PA
    Age
    58
    Posts
    812

    Re: 2001 Seadoo GTX 951 DI starting issue

    You need to go step by step looking for where the voltage is falling down. Step 1 is to measure battery voltage on the battery posts themselves, not on any connected part. A good battery with sufficient charge should show 12.6 volts with no load applied. If low, charge it at a 2 amp rate to avoid internal damage from fast charging. If you're at 12.6, with the meter solidly on the posts, apply the starter as a significant load, Voltage will droop some, but likely be no less than about 10.5 (best estimate here). Lower voltage indicates the battery cannot handle the high starting current. Unfortunately, a "new" part these days doesn't always guarantee a good part. Prove the battery first.

    From there, you can check each battery/starter cable assembly. One probe on one end, and the other probe on the other. If you go post to other end terminal stud, you'll be checking the cable itself, the crimps on the terminations, and the quality of the mating surfaces for proper conduction. You should see no more than a tenth or two voltage drop on a cable assembly when carrying starter current.

    If you're suspect of the relay itself, place a heavy jumper across the main terminals to see if you get sufficient cranking, or you can use the meter to check drop across the contactor.

  8. #8
    I dream skis charliebabb's Avatar
    Join Date
    Dec 2010
    Location
    Brawley
    Posts
    745

    Re: 2001 Seadoo GTX 951 DI starting issue

    I checked the positive and negative cables, starter solenoids, and dess posts. Both skis were good. Something so weird is happening, because both ran great and now they both are doing this. And I haven't done anything to them. Ugh

  9. #9
    I dream skis charliebabb's Avatar
    Join Date
    Dec 2010
    Location
    Brawley
    Posts
    745

    Re: 2001 Seadoo GTX 951 DI starting issue

    Anyone experience this weird DI issue? Im stumped

  10. #10
    Resident Guru SURFnTURF's Avatar
    Join Date
    Sep 2004
    Location
    AUSTRALIA
    Posts
    1,187

    Re: 2001 Seadoo GTX 951 DI starting issue

    Attach a battery jumper cable from the negative side of the battery only and place the other end on the engine,make sure it is grounded properly
    try this and see if does anything

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0