pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 4 of 4
  1. #1
    PWCToday Newbie
    Join Date
    Jul 2017
    Location
    VA
    Posts
    9

    Bought twin 2004 12Fs...need help please

    Hi,

    Last Wednesday I bought a set of 2004 12Fs from the original owner, I won't make this a long story but there is some info which may be beneficial to helping me diagnose the problems. They sat in a field for years, uncovered, had to replace wheels/tires/lights on the trailer just to get them home. I normally would not have bought something like that except that I know this guy and have hired him to do some tree work for me in the past. He said they were both running good when he quite riding them 3 years ago, he said he had fogged both motors. One has 187 hrs and one has 165 hrs. I have named them thunder and lightning and have listed what I've done below:

    Thunder, after new plugs, battery, oil changed, fuel pump, fuel filter, cleaning injectors and emptying and cleaning out gas tank, she fires right up and purrs like a kitten on the hose. I'm surprised at how quiet and smooth it runs.

    Lighting, this one not so much. Motor was totally seized. I poured marvel mystery oil in the spark plug holes and let that sit overnight. It would spin over the next day but had no spark. Replaced crank position pulse coil, now have spark but would try to fire off but not quite, got a code for vehicle down sensor. Replaced that and now it will start and run for about 10 seconds but it "hunts" for idle the whole time it is running and eventually shuts off. From the known good ski, I have swapped the following items onto lighting with no change. MAP, TPS, IAC, ECU, complete fuel rail with injectors and complete throttle body. If I hold the throttle slightly open I can get it to run at about 2K but it still "hunts".
    I'm blowing the seal on oil filters, if it hits 3K rpms it blows the seal. While it is at idle (or hunting in rpms) I can see the filter being lifted as the rpms increase. I have blown out the return line at the filter location with compressed air and I can hear gurgling in the oil pan when I do that so I would assume the return is clear but there has to be a block somewhere or it wouldn't be blowing filters. When it runs, I can see oil coming out the end of the camshaft you can observe with the filler cap removed so it appears that oil is getting to the top end as well. Any ideas on the oil filter issue or idle hunting please?
    I have ordered a service manual but it has not yet arrived. Also waiting on an adapter to fit my compression tester to these little spark plug holes. I have quite a bit of experience with motorcycle engines but have never owned a ski before. I look forward to your ideas and hope to be able to assist others in the future.

    Thanks,
    Mike

  2. #2
    PWCToday Newbie
    Join Date
    Jul 2017
    Location
    VA
    Posts
    9

    Re: Bought twin 2004 12Fs...need help please

    So, I helped myself. Just posting the results in case anyone else dredges this up in a search.

    Thunder runs great, have put about 15 issues free hours on her since I replaced all the above parts. I'll probably replace that under intake manifold water pipe this winter.

    Lightning, compression test numbers were 200/125/145/145 if I put oil in #2 compression came up to 200. Pulled the motor and disassembled it. All compression rings were stuck to all pistons. #1's oil rings were not stuck so I guess that is why the compression numbers on that cylinder were ok. Nikasil on the cylinders looked fine after some PB Blaster on a green scotchbrite pad. Still have good cross-hatch after 180 hrs (where the piston rides)
    Oil pressure regulator valve was rusted stuck closed, this is why I was popping oil filters, got a new one of those, about 50 bucks.
    So, 4 new pistons and rings, timing chain and oil pump drive chain, oil pump rebuild, oil pressure regulator, replaced the pot metal cylinder head water pipe which was mostly corroded, surfaced the head and jug and she is now ready to go back together.

  3. #3
    PWCToday Newbie
    Join Date
    Aug 2017
    Location
    Southern NY
    Posts
    13

    Re: Bought twin 2004 12Fs...need help please

    Good job and congrats on "Thunder and Lightning".

  4. #4
    PWCToday Newbie
    Join Date
    Jul 2017
    Location
    VA
    Posts
    9

    Re: Bought twin 2004 12Fs...need help please

    just an update. I got the motor back together and installed this past weekend. Ski ran great.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0