pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 9 of 9
  1. #1
    PWCToday Newbie
    Join Date
    Jun 2016
    Location
    Quebec
    Posts
    6

    High rev at startup

    I have my SL-650 engine rebuilt recently and a strange phenomena did append twice so far. The first time, I was in the garage checking the spark strength. The engine was cold and I hit the start button without choke. It started right away and went in high rev without touching the throttle. I stopped the engine right away. The next time I started the ski, everything went normal. The second time was yesterday when I came back from a ride. I let the ski cool down for maybe 2 hours, then I hooked it up to the garden hose to flush it from salt water using the right procedure. It started normally and put on the water, but after a few seconds, it went in high rev. I shut the water off and then the engine. I then restarted it and everything went normal. Any idea on what could cause that?
    Thanks

  2. #2
    PWCToday Regular Erikbell714's Avatar
    Join Date
    Mar 2016
    Location
    Menifee, CA
    Age
    25
    Posts
    84

    Re: High rev at startup

    Could be a leak in the gaskets under carb or Intake manifold

  3. #3
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    50
    Posts
    9,698

    Re: High rev at startup

    air leak and or lean condition.
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web sites

    new parts / products / services www.watcon.com
    used parts www.rockcountyjetski.webs.com
    thank you

    Please check out and like WATCON on Facebook

  4. #4
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    50
    Posts
    9,698

    Re: High rev at startup

    Did you determine what caused your original engine to fail?

    The Polaris Fuji's are known for fuel related problems. Go through the fuel system COMPLETELY. Carbs, fuel pump lines, tank pick ups (if pre 95) fuel select, etc.

    Lots of info at www.greenhulk.net
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web sites

    new parts / products / services www.watcon.com
    used parts www.rockcountyjetski.webs.com
    thank you

    Please check out and like WATCON on Facebook

  5. #5
    PWCToday Newbie
    Join Date
    Jun 2016
    Location
    Quebec
    Posts
    6

    Re: High rev at startup

    Quote Originally Posted by john zigler View Post
    Did you determine what caused your original engine to fail?

    The Polaris Fuji's are known for fuel related problems. Go through the fuel system COMPLETELY. Carbs, fuel pump lines, tank pick ups (if pre 95) fuel select, etc.

    Lots of info at www.greenhulk.net
    Hi John,
    First of all, I should mention that when I bought the ski, it was in its original state (auto****, single outlet fuel pump, etc.). Last saison, I removed the auto****, replaced the fuel selector valve with a new one, installed a triple outlet fuel pump. I also removed the carb assembly for carbs rebuild. I ordered Mikuni carb rebuild kitson ebay, but found out afterwardthat they were not genuine Mikuni; I installed the new parts anyway.
    At the end of the season, when I winterized the ski, I found some greasy small pieces on the Mag spark plug, took compression readings and found out it was somewhat low(80-85 psi). I went to the Polaris dealer who told me he was to take a look inside. A few days after he said that the engine needed to be rebuilt. He did it last spring and told me to run it on premix on the first full fuel tank.
    The high rev on startup problem appeared after the engine rebuild process. It did not show up after I rebuilt the carbs.
    Hope it answers your questions.
    Does that ring you a bell?
    Thanks for your comments.

  6. #6
    PWCToday.com Is My Home Away From Home john zigler's Avatar
    Join Date
    Mar 2003
    Location
    wisconsin
    Age
    50
    Posts
    9,698

    Re: High rev at startup

    Hard for me to tell for sure.

    High rev can be from a lean fuel condition. Could be MANY things. Air leak, fuel supply problem, carb problem, etc.
    RCJS also doing business as WATCON
    608-743-1305 9am to 5pm CST m-f
    email watcon@watcon.com

    Please visit our web sites

    new parts / products / services www.watcon.com
    used parts www.rockcountyjetski.webs.com
    thank you

    Please check out and like WATCON on Facebook

  7. #7
    PWCToday Newbie
    Join Date
    Jun 2016
    Location
    Quebec
    Posts
    6

    Re: High rev at startup

    Quote Originally Posted by john zigler View Post
    Hard for me to tell for sure.

    High rev can be from a lean fuel condition. Could be MANY things. Air leak, fuel supply problem, carb problem, etc.
    Hi John,
    I've checked the spark plugs and they are black and a bit oily. If I had a lean condition, they should be white, if I'm right. After inspecting I found a loose wire (my Tiny Tach pick up antenna) in contact with the trottle cam. I thought it was it and corrected the situation and the problem seemed to have disapeared for a few days, but it showed up again this morning while I was flushing the salt water out (jetski hooked on the garden hose). Now I don't know what to look for.
    Thanks for your comments

  8. #8
    PWCToday Newbie
    Join Date
    Jun 2016
    Location
    Quebec
    Posts
    6

    Re: High rev at startup

    Here is an update on the situation. When I removed the auto****, I plugged the pulse line fitting with an automotive rubber cap and tighten it with a zip tie. The dealer found out that the cap was broken, hence air was leaking. It must have been broken either when the engine was removed from the hull or when it was put back in. It was the dealer technician fault and the problem was corrected.
    Thanks guys for your comments.

  9. #9
    PWCToday Newbie
    Join Date
    Jun 2016
    Location
    Quebec
    Posts
    6

    Re: High rev at startup

    Oops!
    Last edited by pol650; 09-06-2017 at 04:33 PM. Reason: Posted twice by error

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0