pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 2 of 2
  1. #1
    PWCToday Newbie
    Join Date
    Jun 2017
    Location
    wpb
    Posts
    1

    2001 Polaris Pro 1200

    I have a Polaris Pro 1200 waverunner. We were out one day running them. The unit was running great. Next thing I know we got pull over and they had us pull up into the weeds. Shut the units off. After they let us go, we took off and off of a sudden, the unit lost power. When we got the unit back to the trailer and loaded, we noticed that there was weeds in the intake tube. We cleaned them out. The next time we tried to take the unit out, we had no power. On the trailer, the unit seams to run fine. But in the water, it has no power. We have checked the intake tube and that seams to be clear. We finally gave up last year and put them up for the winter. Now we want to take them out and are still having the same issue even after it has sat for the past 4 months. Does anybody have an idea of what it might be or what I need to look at?

    Thanks

  2. #2
    Frequent Poster nataliator's Avatar
    Join Date
    Oct 2013
    Location
    PA
    Age
    32
    Posts
    184

    Re: 2001 Polaris Pro 1200

    the pump has a little screen in front of the main cooling intake to prevent the lines for seriously clogging - you are sure its clear and you never overheated the motor?

    If the engine checks out, and you don't have any leftover weeds wrapped up in your intake/driveshaft/prop, then you might have trashed the prop enough that its too much cavitation to get the ski going
    87 650sx Red - 38mm 3 jet, Bored intake, Pipe Mod+TS Mani, Quadrafin plate, Thruster Scoop, Skat 16, 7^ bars, Pole Spring, Lanyard/Bilge Button, Finger Throttle
    88 650sx Blue - 40mm, Bored intake, Pipe Mod+TS Mani, Jetlyne plate, WC Superdeep, Skat 13/16, 4^ bars, Pole Spring, Lanyard/Bilge Button, Finger Throttle

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0