Zxi1100 center piston - Page 5
pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 53
  1. #41
    Frequent Poster a1cnc's Avatar
    Join Date
    Jun 2017
    Location
    NH
    Posts
    201

    Re: Zxi1100 center piston

    That center bearing in the video definitely sounds bad, I bet it feels jumpy when you roll it. Is this supposed to be a new crank or a used one? If new I would contact them and let them know what you found.

    As for using your old crank I would guess you bought a new one because you didn't feel the original was up to snuff. If that is the case then I wouldn't use it either I would try to get the one from pwc engine corrected.

  2. #42
    I dream skis
    Join Date
    May 2011
    Location
    S.nh
    Posts
    740
    Blog Entries
    1

    Re: Zxi1100 center piston

    So.
    I talked with pwcengines.
    He told me it was most likley a tiny bit of grit got in the bearing, flush with wd40 and then 2'stroke oil and it should be fine. I did that this morning and it definitly feels better. I'll install it. Just waiting on oil seals...did the same to my old crank and it feels fine now too...well I'll know next time....hopefully I'll get a couple hundred hours out of this motor when it's all done....

  3. #43
    Frequent Poster a1cnc's Avatar
    Join Date
    Jun 2017
    Location
    NH
    Posts
    201

    Re: Zxi1100 center piston

    Well glad to hear that. I would probably keep flushing them then till you don't feel ANY roughness at all just to be safe.

    I am also glad you are getting closer to running, I need someone to ride with! LOL I took mine out last week for ~2-1/2 hours and my legs are still feeling it a few days later. Dam it sucks getting older!

  4. #44
    I dream skis
    Join Date
    May 2011
    Location
    S.nh
    Posts
    740
    Blog Entries
    1

    Re: Zxi1100 center piston

    IMG_0080.JPGOk trying to assemble today. As usually happens with me , stuff goes missing...at this rat I'll have it running for fall....there are two pins that locate the center crank seals, keeps them from spinning I guess...anyone ever not use one? I'm thinking if I glue it in with a dab of 1200 that would be enough? Thoughts?

  5. #45
    I dream skis
    Join Date
    May 2011
    Location
    S.nh
    Posts
    740
    Blog Entries
    1

    Re: Zxi1100 center piston

    IMG_0081.JPGOk I must have the seals oriented wrong? Can't be off this far....

  6. #46
    I dream skis
    Join Date
    May 2011
    Location
    S.nh
    Posts
    740
    Blog Entries
    1

    Re: Zxi1100 center piston

    Ok I think I've got it, chime in if I'm wrong.....
    Attached Images Attached Images

  7. #47
    I dream skis
    Join Date
    May 2011
    Location
    S.nh
    Posts
    740
    Blog Entries
    1

    Re: Zxi1100 center piston


  8. #48
    I dream skis
    Join Date
    May 2011
    Location
    S.nh
    Posts
    740
    Blog Entries
    1

    Re: Zxi1100 center piston


  9. #49
    Frequent Poster a1cnc's Avatar
    Join Date
    Jun 2017
    Location
    NH
    Posts
    201

    Re: Zxi1100 center piston

    Just looked at my engine in the ski, Far as I can tell on the end the coupling goes on your seal looks right, I can't see the other end. On the pin, do you have a hardware store near by? Bet you could find something close if not the right size.

  10. #50
    I dream skis
    Join Date
    May 2011
    Location
    S.nh
    Posts
    740
    Blog Entries
    1

    Re: Zxi1100 center piston

    IMG_0006.JPGCan someone confirm I have the seals facing correctly?

Page 5 of 6 FirstFirst ... 3456 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0