pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 4 of 4
  1. #1
    PWCToday Guru
    Join Date
    Dec 2005
    Location
    Page, Az
    Age
    61
    Posts
    401

    Kawasaki ultra lx run issue

    I have an 09 Kawasaki ultra lx non s/c that starts and idles fine, runs up to speed, if you let off the throttle fast it stalls but will fire right back up again. Any body else had this happen? I already replaced the throttle body with another known working one from an 07 ultra that I parted out. I also replaced the sensor that goes right below the throttle body. took it to test run same problem. any help would be appreciated.

  2. #2
    PWCToday Newbie
    Join Date
    Feb 2015
    Location
    Southcoast ma
    Age
    57
    Posts
    31

    Re: Kawasaki ultra lx run issue

    Sounds like the ics motor,very common problem

  3. #3
    PWCToday Guru
    Join Date
    Dec 2005
    Location
    Page, Az
    Age
    61
    Posts
    401

    Re: Kawasaki ultra lx run issue

    where is the ics motor located and what does it look like?

  4. #4
    PWCToday Newbie
    Join Date
    Feb 2015
    Location
    Southcoast ma
    Age
    57
    Posts
    31

    Re: Kawasaki ultra lx run issue

    Small electronic motor on throttle body,has 3 small screws holding it on,usually seal goes bad,have to change isc motor. Jet ski will accelerate normal,but will stall when you let off.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0