pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    PWCToday Regular
    Join Date
    Mar 2008
    Location
    so cal
    Age
    34
    Posts
    85

    running on hose, getting water in hull 951 carbed

    Some info, completely stock engine, stock air box, 130 psi in each cylinder.

    While running it on the hose it ran as it should water exiting the lines to outside the hull, but there is about 3" of water in the hull after three minutes run time. I double checked all the lines and hoses and all are in correct locations all clamped down.

    Any idea why water is leaking into the hull?

    After that i lost electric and now no beeping when plugging in dess key. Info center does not light up either. Battery is nearly new and tested good.

    Advice appreciated, thanks in advance!

  2. #2
    PWCToday Regular
    Join Date
    Mar 2008
    Location
    so cal
    Age
    34
    Posts
    85

    Re: running on hose, getting water in hull 951 carbed

    All fuses in front electric box are good. Its a 98 gsxl

  3. #3
    Top Dog sea-one's Avatar
    Join Date
    Aug 2011
    Location
    Dallas tx
    Posts
    1,493

    Re: running on hose, getting water in hull 951 carbed

    Check the welded caps on the pipe
    2004 Rxp Stock Motor with other light mods
    1996 Xp Resurrected july 2014/SOLD 2016
    1991 Kawi 750cc Big pin Twin Carb Sport Cruiser Custom (Resurrected Feb 2015 completed June 2015)
    2000 XP Saved Spring 2016- Resurrected July 2016 as new
    2002 Seadoo ISLANDIA/Sold
    CANDoo Pro system

  4. #4
    PWCToday Regular
    Join Date
    Mar 2008
    Location
    so cal
    Age
    34
    Posts
    85

    Re: running on hose, getting water in hull 951 carbed

    Checked out fine and no leaks from the welded caps.
    Everything from the line and above the motor mount area is dry.
    the black plastic bilge box is covered under water up to the fuel tank and is about 2-3" deep of water.

  5. #5
    resident guru SURFnTURF's Avatar
    Join Date
    Sep 2004
    Location
    AUSTRALIA
    Posts
    1,173

    Re: running on hose, getting water in hull 951 carbed

    has the upper crank case hose come off the fitting it is under the pipe directly inline with the head "water in" hose fitting
    Attached Images Attached Images

  6. #6
    PWCToday.com Is My Home Away From Home PrickofMisery's Avatar
    Join Date
    Mar 2007
    Location
    Is Everything!
    Age
    45
    Posts
    11,911

    Re: running on hose, getting water in hull 951 carbed

    Is the water warm or cold? That will give you a good idea where to start hunting.

  7. #7
    PWCToday Regular
    Join Date
    Mar 2008
    Location
    so cal
    Age
    34
    Posts
    85

    Re: running on hose, getting water in hull 951 carbed

    Surf that is near the 6mm Allen bolt for the counterbalance, that hose is connected.

    Prick the water was cool, not cold, and not warm.

    Im stumped with this. Anymore help appreciated, thanks in advance!

  8. #8
    PWCToday Regular jhjesse's Avatar
    Join Date
    Nov 2009
    Location
    georgia
    Age
    57
    Posts
    143

    Re: running on hose, getting water in hull 951 carbed

    Might check where the tuned pipe connects to the exhaust manifold. Those 4 bolts have been known to loosen up.
    Might also check the hose connection going to the under side of the exhaust at the front of the motor by the oil filter.
    Over analizing is common...simple answers are few.

    Come back to reality!!

  9. #9
    PWCToday Regular
    Join Date
    Mar 2008
    Location
    so cal
    Age
    34
    Posts
    85

    Re: running on hose, getting water in hull 951 carbed

    Those 3, 8mm allen bolts and 15mm nut are tight for sure and it's dry under there with no signs of water leakage from that area.
    the hose under the tuned pipe near oil filter is also on tight along with the three other black lines connected to the pipe.
    The power to the dess key and gauge is also out and what im concerned about, battery tested good and fuses are good.
    thanks for the responses

  10. #10
    PWCToday Regular jhjesse's Avatar
    Join Date
    Nov 2009
    Location
    georgia
    Age
    57
    Posts
    143

    Re: running on hose, getting water in hull 951 carbed

    Quote Originally Posted by pwc enthusiast View Post
    Those 3, 8mm allen bolts and 15mm nut are tight for sure and it's dry under there with no signs of water leakage from that area.
    the hose under the tuned pipe near oil filter is also on tight along with the three other black lines connected to the pipe.
    The power to the dess key and gauge is also out and what im concerned about, battery tested good and fuses are good.
    thanks for the responses
    Maybe trace the above mentioned line back to the pump and look for cracks or rub holes. I believe it goes into a tee just before connecting to the back side of the pump where you install the garden hose. With that much water in the hull in just 3 minutes would lead me to believe the water is coming from the inlet source.
    Over analizing is common...simple answers are few.

    Come back to reality!!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0