pxctoday

» Log in

User Name:

Password:

Not a member yet?
Register Now!

» Find OEM Parts

» Jobs

» wallpapers

Results 1 to 4 of 4
  1. #1
    I dream skis DamageInc's Avatar
    Join Date
    Apr 2014
    Location
    Pismo
    Age
    52
    Posts
    765
    Blog Entries
    1

    Carb issues 750 slt

    I just installed the mikuni 3 outlet fuel pump, but I'm only getting fuel to the pto carb. All 3 carbs have new rebuild kits, and lines are clear.
    Is this a common issue?

    image.jpg
    96 xp stocker w/ the works
    96 xp stocker
    96 xp project
    92 X2 650/750 conv build

    90 JS440/650sx conversion
    04 YfZ450
    05 GSXR 1000

  2. #2
    Frequent Poster nataliator's Avatar
    Join Date
    Oct 2013
    Location
    PA
    Age
    31
    Posts
    179

    Re: Carb issues 750 slt

    edit: pic is too huge to see where the lines go.

    OP is everything hooked up right?
    Last edited by nataliator; 03-21-2017 at 12:35 PM.
    87 650sx Red - 38mm 3 jet, Bored intake, Pipe Mod+TS Mani, Quadrafin plate, Thruster Scoop, Skat 16, 7^ bars, Pole Spring, Lanyard/Bilge Button, Finger Throttle
    88 650sx Blue - 40mm, Bored intake, Pipe Mod+TS Mani, Jetlyne plate, WC Superdeep, Skat 13/16, 4^ bars, Pole Spring, Lanyard/Bilge Button, Finger Throttle

  3. #3
    I dream skis DamageInc's Avatar
    Join Date
    Apr 2014
    Location
    Pismo
    Age
    52
    Posts
    765
    Blog Entries
    1

    Re: Carb issues 750 slt

    Yes, all lines are correct.
    I pulled the carbs off. Will open them back up and see if I missed something.
    All new black fuel lines as well...
    96 xp stocker w/ the works
    96 xp stocker
    96 xp project
    92 X2 650/750 conv build

    90 JS440/650sx conversion
    04 YfZ450
    05 GSXR 1000

  4. #4
    PWCToday Newbie ripcuda's Avatar
    Join Date
    Jun 2011
    Location
    Spokane, WA
    Posts
    32

    Re: Carb issues 750 slt

    Hard to see clearly where all the lines are going... assuming the IN line is looping around behind the mounting bracket... it does appear you are plumbing it in correctly.

    How are you determining you are only getting fuel to the PTO carb?
    Have you rebuilt the carbs?
    It's possible the fuel seats are sticking in the carb and not letting fuel in.

    NOTE TO EVERYBODY:
    The blue Fuji engines in these older Polaris are 20+ years old now... and the fuel system is their Achilles Heal. You REALLY need to rebuild (not just clean) the carbs... with genuine Mikuni rebuild kits (yes... they are $50 per carb!)... and you definitely should upgrade to a new 3-outlet Mikuni fuel pump ($30 new). Carb jetting stays the same with triple-outlet pump.


    Cheers!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.2.0